Bug 38218 - RPM 4.0.3-0.7 and later can't handle %ghost attributes in %files
RPM 4.0.3-0.7 and later can't handle %ghost attributes in %files
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm (Show other bugs)
1.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
: 38217 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-28 15:17 EDT by Jaroslaw Sosnicki
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-29 19:44:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from rpm -bb apache.spec (72.56 KB, text/plain)
2001-04-28 17:25 EDT, Jaroslaw Sosnicki
no flags Details

  None (edit)
Description Jaroslaw Sosnicki 2001-04-28 15:17:11 EDT
RPM 4.0.3-0.8 fails to build apache-1.3.19-5.src.rpm
it builds OK on rpm-4.0.3-0.4

if you need additional info let me know.

Here is a list of libs installed on my system (all components form
rawhide-release-20010424-1
-------
compat-libstdc++-6.2-2.9.0.14
cracklib-2.7-8
cracklib-dicts-2.7-8
glib-1.2.10-2
glibc-2.2.2-10
glibc-common-2.2.2-10
glibc-devel-2.2.2-10
glibc-profile-2.2.2-10
glib-devel-1.2.10-2
gnome-libs-1.2.13-1
gnome-libs-devel-1.2.13-1
imlib-1.9.10-1
imlib-cfgeditor-1.9.10-1
imlib-devel-1.9.10-1
kdelibs-2.2-0.alpha1.2
kdelibs-devel-2.2-0.alpha1.2
kdelibs-sound-2.2-0.alpha1.2
krb5-libs-1.2.2-4
libgal3-0.4.1-3
libghttp-1.0.9-1
libghttp-devel-1.0.9-1
libglade-0.16-1
libglade-devel-0.16-1
libgnomeprint11-0.25-9
libgtop-1.0.12-1
libgtop-devel-1.0.12-1
libjpeg-6b-15
libjpeg-devel-6b-15
libmng-1.0.0-2
libmng-devel-1.0.0-2
libole2-0.1.7-2
libpng-1.0.10-1
libpng-devel-1.0.10-1
librep-0.13.3-1
libstdc++-2.96-81
libstdc++-devel-2.96-81
libtermcap-2.0.8-26
libtermcap-devel-2.0.8-26
libtiff-3.5.5-10
libtiff-devel-3.5.5-10
libtool-1.3.5-8
libtool-libs-1.3.5-8
libungif-4.1.0-7
libungif-devel-4.1.0-7
libunicode-0.4-4
libxml-1.8.11-2
libxml-devel-1.8.11-2
pygnome-libglade-0.6.6-8
pygtk-libglade-0.6.6-8
pythonlib-1.28-1
rep-gtk-libglade-0.15-4
tcllib-0.4-53
VFlib2-2.25.1-12
XFree86-libs-4.0.3-10
zlib-1.1.3-22
zlib-devel-1.1.3-22
Comment 1 Jeff Johnson 2001-04-28 15:52:37 EDT
Almost certainly fixed in rpm-4.0.3-0.9 from
ftp.rpm.org:/pub/rpm/test-4.0.3-ROLLBACKS,
as symlinks were not packaged correctly in -0.8. More breakage is expected ...

Next time can you be more specific about "fails to build". Thanks.
Comment 2 Jeff Johnson 2001-04-28 15:53:17 EDT
*** Bug 38217 has been marked as a duplicate of this bug. ***
Comment 3 Jaroslaw Sosnicki 2001-04-28 17:25:52 EDT
Created attachment 16745 [details]
Output from rpm -bb apache.spec
Comment 4 Jaroslaw Sosnicki 2001-04-28 17:27:03 EDT
I am still having the same problem with rpm-4.0.3-0.9 
I am attachin complete output from rpm -bb apache.spec
Comment 5 Jeff Johnson 2001-04-29 19:42:25 EDT
There are 3 %ghost lines in the mod_ssl sub-package:
    %attr(0600,apache,root) %ghost %{_localstatedir}/cache/ssl_gcache_data.dir
    %attr(0600,apache,root) %ghost %{_localstatedir}/cache/ssl_gcache_data.pag
    %attr(0600,apache,root) %ghost %{_localstatedir}/cache/ssl_gcache_data.sem
that can be commented out to build with rpm-4.0.3-0.7 and later.

Otherwise, build with rpm-4.0.2, as it will be a while before I fix %ghost in
rpm-4.0.3
Comment 6 Jeff Johnson 2001-05-21 11:59:39 EDT
Fixed in rpm-4.0.3-0.25.

Note You need to log in before you can comment on or make changes to this bug.