Bug 38268 - up2date can't install postfix package
Summary: up2date can't install postfix package
Status: CLOSED DUPLICATE of bug 38192
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-29 09:36 UTC by Need Real Name
Modified: 2015-01-07 23:45 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-11 21:10:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-04-29 09:36:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i686)


If I try to install postfix with the command 'up2date -i postfix'  the
up2date program
crashes. 

Reproducible: Always
Steps to Reproduce:
1. Type up2date -i postfix


Actual Results:  [root@localhost nickus]# up2date -i postfix
 
Retrieving list of all available packages...
 
Removing installed packages from list of updates...
########################################
 
Removing packages with files not specified from list...
 
Removing packages marked to skip from list...
########################################
 
Getting headers for available packages...
########################################
 
Removing packages with files marked to skip from list...
########################################
 
Testing package set / solving RPM inter-dependencies...
Traceback (innermost last):
  File "/usr/sbin/up2date", line 831, in ?
    main()
  File "/usr/sbin/up2date", line 806, in main
    sys.exit(batchRun(onlyList, pkgNames, fullUpdate))
  File "/usr/sbin/up2date", line 534, in batchRun
    (depPackages, conflicts) = up2date.dryRun(selPkgList, printCallback,
percentCallback)
  File "/usr/share/rhn/up2date/up2date.py", line 2085, in dryRun
    ret = depsolve.solvedep()
  File "/usr/share/rhn/up2date/up2date.py", line 2051, in solvedep
    ret = self.process_deps(deps)
  File "/usr/share/rhn/up2date/up2date.py", line 2021, in process_deps
    changed = changed + self.__conflicts(conflicts)
  File "/usr/share/rhn/up2date/up2date.py", line 1973, in __conflicts
    added = self.__add(solved, check = 1)
  File "/usr/share/rhn/up2date/up2date.py", line 1885, in __add
    h_list = getHeaders(plist, refreshCallback = self.refreshCallback)
  File "/usr/share/rhn/up2date/up2date.py", line 832, in getHeaders
    ret = s.up2date.header(getSystemId(), listToFetch)
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 608, in
__call__
    return self.__send(self.__name, args)
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 644, in
__request
    request = dumps(params, methodname)
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 482, in dumps
    data = m.dumps(params)
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 251, in dumps
    self.__dump(v)
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 264, in __dump
    f(self, value)
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 290, in
dump_array
    self.__dump(v)
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 264, in __dump
    f(self, value)
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 286, in
dump_array
    self.container(value)
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 282, in
container
    raise TypeError, "cannot marshal recursive data structures"
TypeError: cannot marshal recursive data structures

Expected Results:  That the package should be downloaded and installed :-).

Comment 1 Adrian Likins 2002-02-11 21:10:13 UTC
This is a bug in the xmlrpc package, and has been fixed
in current releases.

Comment 2 David M. Cook 2002-03-11 18:42:51 UTC

*** This bug has been marked as a duplicate of 38192 ***


Note You need to log in before you can comment on or make changes to this bug.