Bug 383061 - F7 needs Alpine version bump to .99999
F7 needs Alpine version bump to .99999
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: alpine (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Jima
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-14 13:59 EST by Gilbert Sebenste
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version: .99999
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-22 20:58:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gilbert Sebenste 2007-11-14 13:59:46 EST
Description of problem: Need a build of Alpine .99999 for F7.


Version-Release number of selected component (if applicable): .9999


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info: Alpine is stuck at .9999 for F7, but needs a bump to fix
problems, such as no spell checking. New release is .99999 and has been released
for F8 and F9. Any chance for a quick compile on Koji?
Comment 1 Jima 2007-11-14 14:42:07 EST
I'm the one who built it in the first place for F-7, so I'll take care of this.
 Still trying to decide whether to push it to updates-released, since F-8 now
has it mainline.
Comment 2 Rex Dieter 2007-11-14 14:46:24 EST
jima, "just do it" (c).  :)
Comment 3 Gilbert Sebenste 2007-11-14 14:54:28 EST
Thanks, Jima.

I am still trying to figure out how to get the Spell checker to work. By
default, it doesn't. Others on the 'net are reporting the same thing, even with
.99999.
Comment 4 Gilbert Sebenste 2007-11-14 14:55:10 EST
Oh, and do push it to updates-released. Despite the spell-check problem, it
works well.
Comment 5 Jima 2007-11-14 15:15:54 EST
I just requested it be pushed to updates-testing.  (We'll decide where to move
from there.)  I wonder if the spell check issue might be a missing dependency?
Comment 6 Gilbert Sebenste 2007-11-14 15:20:59 EST
Other repos are having the same problem, it could very well be. But I don't 
know how to file a bug with Alpine users directly.
Comment 7 Fedora Update System 2007-11-14 22:37:56 EST
alpine-0.99999-2.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update alpine'
Comment 8 Gilbert Sebenste 2007-11-14 23:20:54 EST
I will reopen this ticket on account of the fact that the spell-checker doesn't 
work. Hitting control-T to spellcheck leaves a file in the /tmp directory, but 
does not do anything. Linking to aspell doesn't work, it gives an error message.
Comment 9 Joshua Daniel Franklin 2007-11-15 01:31:49 EST
Sorry, I didn't realize you'd done the Fedora 7 branch or I would have updated
there, too.

The spell check works for me, though I do see the pico tmp files left around.
Comment 10 Need Real Name 2007-11-15 06:55:19 EST
The configure invocation in the spec file needs updating to
"--with-simple-spellcheck=aspell". This fixed it for me.(In reply to comment #8)
> I will reopen this ticket on account of the fact that the spell-checker doesn't 
> work. Hitting control-T to spellcheck leaves a file in the /tmp directory, but 
> does not do anything. Linking to aspell doesn't work, it gives an error message.

Comment 11 Gilbert Sebenste 2007-11-15 10:41:19 EST
Real (comment #10): SOmething needs to be put in pine.conf to get it fixed, 
though. By default, it won't go. And yes, the files left behind are a security 
problem.
Comment 12 Rex Dieter 2007-11-15 11:19:48 EST
pine.conf should have (something like):
speller=aspell --mode=email -c
Comment 13 Joshua Daniel Franklin 2007-11-15 13:27:51 EST
I cannot reproduce anything other than the leftover pico tmp file
(which is a bug that I will report upstream). 

Here is what works for me:
I have Fedora's alpine-0.99999-2 installed and aspell. 
I start alpine and go to compose, then type "grean" or
any misspelled word and ctrl-T and aspell comes up normally.

This works with no pine.conf or .pinerc, or with my own .pinerc.
Do you perhaps have a different "speller=" line left over from
an old install? If not can you provide your installation details
and what you see?
Comment 14 Rex Dieter 2007-11-15 13:35:47 EST
For me, if no pine conf file contains speller=... I get an error when pressing ^T:
Spell-checking file "" not found
Comment 15 Gilbert Sebenste 2007-11-15 13:40:00 EST
Rex,

That is what I am seeing also. If I have:

speller=

Then I get that error.
Comment 16 Rex Dieter 2007-11-15 14:46:13 EST
Gilbert, can you file a new bug repot about that please (strictly speaking it's
offtopic here).
Comment 17 Gilbert Sebenste 2007-11-15 14:56:37 EST
Done.

https://bugzilla.redhat.com/show_bug.cgi?id=385401

Feel free to close this one, and put all follow-ups on the new bug report.

Note You need to log in before you can comment on or make changes to this bug.