Bug 383631 - Pirut crashes when search button pressed.
Pirut crashes when search button pressed.
Status: CLOSED DUPLICATE of bug 388631
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-14 19:34 EST by Orlando Arias
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-19 11:21:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Report log. (620 bytes, application/octet-stream)
2007-11-14 19:34 EST, Orlando Arias
no flags Details

  None (edit)
Description Orlando Arias 2007-11-14 19:34:33 EST
Description of problem:
Pirut crashed after unhandled exception.

Actual results:

Component: pirut
Summary: TBc6f5b1a6 pirut:166:_stopSearch:AttributeError: 'NoneType' object has
no attribute 'show'

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 213, in _searchClicked
    self._stopSearch(stop, xml) # it's done
  File "/usr/sbin/pirut", line 166, in _stopSearch
    search.show()
AttributeError: 'NoneType' object has no attribute 'show'

Local variables in innermost frame:
xml: <glade.XML object at 0xa55f374 (PyGladeXML at 0x8f7ba20)>
search: None
stop: None
widget: <gtk.Button object at 0xaabfc5c (GtkButton at 0x89dd290)>
self: <__main__.PackageManager object at 0x8d3accc>


Expected results:

Search performed.
Comment 1 Orlando Arias 2007-11-14 19:34:33 EST
Created attachment 259171 [details]
Report log.
Comment 2 Jeremy Katz 2007-11-15 20:08:44 EST
What's the output of 'rpm -V pirut'?  Can you get this to happen reliably?
Comment 3 Orlando Arias 2007-11-18 15:08:53 EST
rpm -V pirut has no output.

Have not been able to replicate bug. Pirut crashed when searching for packages
and I clicked stop.
Comment 4 Jeremy Katz 2007-11-19 11:21:10 EST

*** This bug has been marked as a duplicate of 388631 ***

Note You need to log in before you can comment on or make changes to this bug.