Bug 383641 - mdadm.conf incorrect, prevents boot after upgrade with 2 raid devices
Summary: mdadm.conf incorrect, prevents boot after upgrade with 2 raid devices
Status: CLOSED DUPLICATE of bug 242334
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 8
Hardware: x86_64 Linux
low
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-15 00:44 UTC by Jon Burgess
Modified: 2008-05-07 13:58 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-07 13:58:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jon Burgess 2007-11-15 00:44:40 UTC
Description of problem:
Working F7 system was upgraded to F8. Install completed OK. Failed to boot after
upgrade. Complaint about md1 missing from mdadm.conf in startup messages

Version-Release number of selected component (if applicable):
F8 x86_64 DVD iso with updates-f8-yumloop.img

How reproducible:


Steps to Reproduce:
1. F7 system with 4 SATA disks on AHCI controller as sda,sdb,sdc,sdd
2. /dev/md0 = RAID1 of sda1, sdb1, sdc1, sdd1
3. /dev/md1 = RAID5 of sda2, sdb2, sdc2, sdd2
4. Boot F8 x86_64 installation via USB HD with DVD iso file
5. Use updates-f8-yumloop.img from Bug 372011 to get past depsolve issue
6. Complete upgrade successfully and reboot.
  
Actual results:
Kernel & initrd loads. When it fails to start md1 and then panics when it can
not locate the root fs.

Expected results:
Working system

Additional info:
The mdadm.conf file written by anaconda was missing an entry for md1:-

# mdadm.conf written out by anaconda
DEVICE partitions
MAILADDR root
ARRAY /dev/md0 level=raid1 num-devices=4 uuid=f2aa16e2:2bcef9bd:ff08a61c:f6868636

The same thing happened with f7t4 a few months ago, see Bug 240952
It can be fixed by adding the appropriate md1 line as per the previous bug.

Comment 1 Phil Anderson 2007-12-19 13:33:59 UTC
I can confirm this bug when upgrading from FC7 to FC8.  I have 3 raid devices
(md0 - raid 1, md1 - raid 5 and md2 - raid 0).  anaconda somehow missed out md1
from my mdadm.conf, causing an unbootable system.

Not sure why you think this is a low priority bug - I would have thought it
should be medium or high.

Comment 2 Phil Anderson 2007-12-19 13:35:08 UTC
this is a duplicate of 242334.

Comment 3 Joel Andres Granados 2008-05-07 13:58:48 UTC

*** This bug has been marked as a duplicate of 242334 ***


Note You need to log in before you can comment on or make changes to this bug.