Bug 383671 - Software Updater asked me to report this bug
Summary: Software Updater asked me to report this bug
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rhn-client-tools (Show other bugs)
(Show other bugs)
Version: 5.0
Hardware: All Linux
low
high
Target Milestone: ---
: ---
Assignee: John Matthews
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-15 01:42 UTC by Bill Watson
Modified: 2008-06-11 14:59 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-11 14:59:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
downloading kdebase-3.5.4-15.el5.i386.rpm got an unhandled error (2.38 KB, text/plain)
2007-11-15 01:42 UTC, Bill Watson
no flags Details

Description Bill Watson 2007-11-15 01:42:36 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
while the updater was downloading kdebase-3.5.4-15.el5.i386.rpm it had "An 
unhandled exception  has occurred. This is most likely a bug. Please save the 
crash dump and file a detailed report against Software Updater at 
https://bugzilla.redhat.com/bugzilla .


Steps to Reproduce:
1. from GUI click [Applications] [System Tools] [Software Updater]
2.
3.
  
Actual results:
ran for hours then errored

Expected results:
no error report


Additional info:
Component: Software Updater
Summary: TBc99d7ef3 Connection.py:184:_read_bio:SSLError: (104, 'Connection 
reset by peer')

Traceback (most recent call last):
  File "/usr/sbin/pup", line 438, in _apply
    self.applyChanges(self.mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 561, in 
applyChanges
    dlpkgs = self.downloadPackages(mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 273, in 
downloadPackages
    probs = self.downloadPkgs(dlpkgs)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 690, in 
downloadPkgs
    cache=po.repo.http_caching != 'none',
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 447, in 
getPackage
    cache=cache
  File "/usr/lib/yum-plugins/rhnplugin.py", line 208, in _YumRepository__get
    start, end, copy_local, checkfunc, text, reget, cache)
  File "/usr/lib/yum-plugins/rhnplugin.py", line 276, in _noExceptionWrappingGet
    http_headers=headers,
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 927, in 
urlgrab
    return self._retry(opts, retryfunc, url, filename)
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 845, in 
_retry
    r = apply(func, (opts,) + args, {})
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 915, in 
retryfunc
    fo._do_grab()
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 1216, in 
_do_grab
    block = self.read(bs)
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 1281, in 
read
    self._fill_buffer(amt)
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line 1259, in 
_fill_buffer
    new = self.fo.read(readamount)
  File "/usr/lib64/python2.4/socket.py", line 303, in read
    data = self._sock.recv(recv_size)
  File "/usr/lib64/python2.4/httplib.py", line 480, in read
    s = self.fp.read(amt)
  File "/usr/lib64/python2.4/socket.py", line 303, in read
    data = self._sock.recv(recv_size)
  File "/usr/lib64/python2.4/site-packages/M2Crypto/SSL/Connection.py", line 
199, in read
    return self._read_bio(size)
  File "/usr/lib64/python2.4/site-packages/M2Crypto/SSL/Connection.py", line 
184, in _read_bio
    return m2.ssl_read(self.ssl, size, self._timeout)
SSLError: (104, 'Connection reset by peer')

Local variables in innermost frame:
self: <M2Crypto.SSL.Connection.Connection instance at 0x5ffcbd8>
size: 6740

Comment 1 Bill Watson 2007-11-15 01:42:36 UTC
Created attachment 259201 [details]
downloading kdebase-3.5.4-15.el5.i386.rpm got an unhandled error

Comment 2 John Matthews 2008-06-11 14:59:55 UTC
The error described here looks to be related to a network error.  

Please re-open this bug if you believe this to not be the case, in addition
please provide any further info you have which may aid us in debugging the cause.






Note You need to log in before you can comment on or make changes to this bug.