Bug 383771 - Unable to update openldap
Unable to update openldap
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-14 22:03 EST by Matthieu Pupat
Modified: 2014-01-21 18:00 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 09:32:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matthieu Pupat 2007-11-14 22:03:47 EST
When updating openlap lum complains about conflicting files:

Transaction Check Error:
  file /usr/share/man/man5/ldap.conf.5.gz from install of openldap-2.3.39-1.fc8
conflicts with file from package openldap-2.3.38-3.fc8
  file /usr/share/man/man5/ldif.5.gz from install of openldap-2.3.39-1.fc8
conflicts with file from package openldap-2.3.38-3.fc8
Comment 1 James Antill 2007-11-15 09:32:36 EST
 What command did you run?
 That looks like a multilib type problem, Ie. only openldap.x86_64 is getting
updated and so openldap.i386 (old version) conflicts with openldap.x86_64 (new
version). This is fixed upstream, but today you should be able to tell yum to
update both (unless only one version is released ... then you'll have to remove
the one that doesn't exist or wait for it to be released).
Comment 2 Matthieu Pupat 2007-11-15 19:39:17 EST
From some more tries:

yum update openldap.i386   -> KO
yum update openldap.x86_64 -> KO
yum update openldap        -> OK

Maybe the error removed and both packages proposed for update?

Note You need to log in before you can comment on or make changes to this bug.