Bug 383791 - Unable to use X with Radeon 9200 in F8
Summary: Unable to use X with Radeon 9200 in F8
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati   
(Show other bugs)
Version: 8
Hardware: i686 Linux
low
medium
Target Milestone: ---
Assignee: Dave Airlie
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-15 03:08 UTC by Bruno Wolff III
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version: 6.7.196-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-27 04:53:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (50.32 KB, text/plain)
2007-11-15 03:15 UTC, Bruno Wolff III
no flags Details
xorg.conf (18 bytes, text/plain)
2007-11-15 03:18 UTC, Bruno Wolff III
no flags Details
xorg.conf (1.24 KB, text/plain)
2007-11-15 03:19 UTC, Bruno Wolff III
no flags Details
Xorg.0.log from another xorg.conf (48.85 KB, text/plain)
2007-11-16 19:18 UTC, Bruno Wolff III
no flags Details
An xorg.conf that refers to both controllers on the card by BusID (1.65 KB, text/plain)
2007-11-16 19:22 UTC, Bruno Wolff III
no flags Details
xorg.conf using vesa driver (993 bytes, text/plain)
2007-11-18 08:59 UTC, Bruno Wolff III
no flags Details
Xorg.0.log from vesa driver (60.02 KB, text/plain)
2007-11-18 09:00 UTC, Bruno Wolff III
no flags Details
xorg.conf that works with xorg-x11-drv-ati-6.7.196-1.fc8 (1.01 KB, text/plain)
2007-11-21 08:03 UTC, Bruno Wolff III
no flags Details
Xorg.0.log from successful use after install xorg-x11-drv-ati-6.7.196-1.fc8 (57.99 KB, text/plain)
2007-11-21 08:04 UTC, Bruno Wolff III
no flags Details

Description Bruno Wolff III 2007-11-15 03:08:49 UTC
Description of problem:I am unable to get X to display output on my monitor since upgrading to F8.
I have X working on another F8 instance with a different video card. The 9200 was usable under f7, though I needed to use an xorg.conf file since my monitor type wasn't detected.
I have tried a number of variations on the xorg.conf file but haven't gotten anything to display yet. In some cases X seems to start, but the monitor doesn't appear to get a video signal. I suspect that the issue is related to the card having two output ports and that it is putting out the signal on the VGA port instead of the DVI port. I will be attaching a sample xorg.conf and correspond Xorg.0.log file.
Version-Release number of selected component (if applicable):xorg-x11-drv-ati-6.7.195-3.fc8


How reproducible:I haven't gotten X to work since upgrading to F8 (after restarting it, X did stay up during the upgrade process).


Steps to Reproduce:I have been using telinit 5/3 to test xorg.conf files.
1.
2.
3.
  
Actual results:No X output on my monitor.


Expected results:A normal X display.


Additional info:

Comment 1 Bruno Wolff III 2007-11-15 03:15:19 UTC
Created attachment 259291 [details]
Xorg.0.log

If you also need lspci output I can provide that, but it looks like what you
need is probably here.

Comment 2 Bruno Wolff III 2007-11-15 03:18:45 UTC
Created attachment 259311 [details]
xorg.conf

This is the xorg.conf file I was using when the previously added Xorg.0.log
file was created.
In this case the X server seemed to start, but no video seemed to get sent to
the monitor.
I didn't get the error message displays as I did when the was an error detected
in the xorg.conf file. I used ctrl+alt+f1 to get back to a VT for more testing.

Comment 3 Bruno Wolff III 2007-11-15 03:19:08 UTC
Created attachment 259321 [details]
xorg.conf

This is the xorg.conf file I was using when the previously added Xorg.0.log
file was created.
In this case the X server seemed to start, but no video seemed to get sent to
the monitor.
I didn't get the error message displays as I did when the was an error detected
in the xorg.conf file. I used ctrl+alt+f1 to get back to a VT for more testing.

Comment 4 Bruno Wolff III 2007-11-15 03:26:42 UTC
I made a typo on my first try at attaching xorg.conf, so skip comment 2.
(Hey, I'm using lynx since I can't use firefox without X and I haven't used it much lately.)

Comment 5 Dave Airlie 2007-11-15 03:41:08 UTC
you have a DVI monitor attached? which doesn't do EDID? what make/model please
as that seems wrong and is totally against DVI specifications..



Comment 6 Bruno Wolff III 2007-11-15 05:28:50 UTC
The monitor is that described by the monitor0 entry in xorg.conf (i.e. NEC MultiSync LCD2010X). I am not sure whether or not it does EDID. It is a relatively old model LCD, so maybe it doesn't.

Comment 7 Bruno Wolff III 2007-11-16 19:18:37 UTC
Created attachment 261691 [details]
Xorg.0.log from another xorg.conf

I am attaching another log file where I used a config that referred to both
controllers on the card by busid.

Comment 8 Bruno Wolff III 2007-11-16 19:22:04 UTC
Created attachment 261711 [details]
An xorg.conf that refers to both controllers on the card by BusID

I tried some more xorg.conf configurations today. I was trying to see if I
could combined both outputs in a way that would leave what I wanted on the DVI
output. It didn't work, but I thought the configuration was different enough
that its output might be useful.

Comment 9 Bruno Wolff III 2007-11-18 08:57:36 UTC
I got the vesa driver working so I lowered the severity to medium. The display
is a lot slower with that driver, but I can get most stuff I want to do done
easier now.
I had tried the vesa driver before, but for some reason it didn't work for me
that time.
For comparison I'll include the vesa xorg.conf and Xorg.0.log files.

Comment 10 Bruno Wolff III 2007-11-18 08:59:26 UTC
Created attachment 262751 [details]
xorg.conf using vesa driver

Comment 11 Bruno Wolff III 2007-11-18 09:00:59 UTC
Created attachment 262761 [details]
Xorg.0.log from vesa driver

Comment 12 Bruno Wolff III 2007-11-21 08:00:05 UTC
xorg-x11-drv-ati-6.7.196-1.fc8 from updates testing fixes this issue for me.
I'll leave this open for now, but will close it if I see it pushed out to the
regular updates repository.
I'll also include updated xorg.conf and Xorg.0.log files for completeness.

Comment 13 Bruno Wolff III 2007-11-21 08:03:12 UTC
Created attachment 265751 [details]
xorg.conf that works with xorg-x11-drv-ati-6.7.196-1.fc8

Comment 14 Bruno Wolff III 2007-11-21 08:04:41 UTC
Created attachment 265761 [details]
Xorg.0.log from successful use after install xorg-x11-drv-ati-6.7.196-1.fc8

Comment 15 Bruno Wolff III 2007-11-27 04:53:20 UTC
6.7.196-1.fc8 is now in updates, so I am closing this.


Note You need to log in before you can comment on or make changes to this bug.