Bug 38390 - install hangs during probe for IDEs
install hangs during probe for IDEs
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-30 09:11 EDT by Mike Edwards
Modified: 2007-04-18 12:32 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-06 08:00:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Edwards 2001-04-30 09:11:35 EDT
I looked for this bug, but didn't see anything posted that I thought was the same.  My apologies if I missed something.

Dell Dimension P350 box w/ 128MB RAM
Onboard IDE controller connected to two hard drives (ide0) and an NEC
    CD-ROM and an HP CD-RW (ide1)
CMD PCI-0649 Ultra DMA IDE Controller connected to a Seagate STT20000A TBU

When I attempt to upgrade to 7.1 from 7.0, either in graphic mode or in text mode, I get
the following output (I only wrote down what I thought was the
relevant output--little else showed up anyway) and then it hangs:

=====
Uniform Multi-Platform E-IDE Driver Revision: 6.31
ide: Assuming 33MHz system bus speed for pio modes; override with
idebus=xx
PIIx4: IDE Controller on PCI bus 00 dev 39
PIIx4: chipset revision 1
PIIx4: not 100% native mode: will probe IRQs later
    ide0: BM-DMA at 0x1420-0x1427, BIOS settings: hda: pio, hdb: DMA
    ide1: BM-DMA at 0x1428-0x142f, BIOS settings: hdc: pio, hdd: DMA
CMD649: IDE Controller on PCI bus 00:0e.0
PCI: found IRQ 11 for device 00:0e.0
CMD649: chipset revision 1
CMD649: not 100% native mode: will probe IRQs later
    ide2: BM-DMA at 0x1430-0x1437, BIOS Settings: hde: pio, hdf: pio
    ide3: BM-DMA at 0x1438-0x143f, BIOS settings: hdg: pio, hdh: pio
hda: Maxtor 91010D6, ATA Disk Drive
hdb: ST320413A
hdc: NEC CD-ROM Drive:28D, ATAPI CD/DVD-ROM Drive
hdd: HP CD-Writer Plus 9300, ATAPI CD/DVD-ROM Drive
hde: Seagate STT20000A, ATAPI Tape Drive
ide: Assuming 33MHz system bus speed
    ide0 at 0x1f0-0x1f7, 0x3f6 on IRQ 14
    ide1 at 0x170-0x177, 0x376 on IRQ 15
=====

And that's it.  It hangs right there and I have to cycle power.  No other
consoles are available; no three-finger bucky (CTRL-ALT-DEL).  Nothin'.

This system boots into RHL 7.0 OK, but I was never able to talk to the CMD card.

FWIW, this is a dual-boot box and it boots fine into Windows 98, including
recognizing the CMD card and the tape drive.

Oh yeah, and the BIOS has a setting for Plug and Play OS.  I have it set to "NO".
Comment 1 Brent Fox 2001-04-30 11:20:01 EDT
This sounds like a kernel problem.
Comment 2 Arjan van de Ven 2001-04-30 11:22:47 EDT
Could you try adding "ide=nodma" to the kernel commandline?
(eg "linux ide=nodma" on the syslinux prompt)
Comment 3 Mike Edwards 2001-04-30 16:03:45 EDT
I tried "ide=nodma" this afternoon but received the same results.  I suppose I could try removing the card and upgrading from there and worry 
about the TBU after the upgrade...
Comment 4 Need Real Name 2001-05-01 12:09:48 EDT
Same exact hang with a Promise UDMA 66 controler (PDC20262).  Connecting the
UDMA66 hard disk to the regular IDE controller works, but even then there's dma
timeouts. Eventually the kernel turns off the dma and the system proceeds to
boot.
Comment 5 Arjan van de Ven 2001-05-01 12:11:52 EDT
ide=nodma should disable dma from the start.
Comment 6 Mike Edwards 2001-05-09 09:17:47 EDT
arjanv: That may be, but since it isn't solving the problem, what course of action do you reccomend?
Comment 7 Arjan van de Ven 2001-05-09 09:21:03 EDT
Can you try disabling the ide1 controller in the bios? If it boots with that,
we know this one is to blame....
Comment 8 Need Real Name 2001-05-10 14:01:53 EDT
I am having a very similar problem with the Promise FastTrak100 IDE RAID 
controller. Except my boot process gets a (very) little bit farther:

<snip>
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
VP_IDE: VIA vt82c686b (rev 40) IDE UDMA100 controller on pci00:07.1
    ide0: BM-DMA at 0xc000-0xc007, BIOS settings: hda:pio, hdb:DMA
    ide1: BM-DMA at 0xc008-0xc00f, BIOS settings: hdc:pio, hdd:pio
PDC20267: IDE Controller on PCI bus dev 48
PCI: Found IRQ 11 for device 00:09.0
PDC20267: chipset revision 2
PDC20267: not 100% native mode: will probe irqs later
PDC20267: (U)DMA Burst Bit ENABLED Primary MASTER Mode Secondary MASTER Mode.
PDC20267: neither IDE port enabled (BIOS)

And there it hangs. I actually took one of the drives off the Raid card, 
completed the install using the on-board IDE channel, and then moved the drive 
back into the mirrored raid setup, so it's booting this far off of the IDE raid 
controller, but will not get beyond this point.

I tried disabling on board controllers, and ide=nodma, and every possible 
setting related to the IDE controllers (on board & promise) with no change in 
where the boot hangs.

System is white box Tyan S2930B (Trinity KT-A) based w/512MB, 1GHz Athlon 
(@266fsb), 3C905B-TX-M, TNT2 Vanta 8MB Video, IBM 60GXP (x2) on the FastTrak 
100, Generic 40x CD-ROM (Teac perhaps). Using the Promise provided linux 
drivers for the FastTrack100.
Comment 9 Arjan van de Ven 2001-05-10 14:09:12 EDT
"Using the Promise provided linux drivers for the FastTrack100."
These drivers are very very very buggy and will eat your filesystems if they
don't crash your kernel.

And as they are binary only, we cannot fix them. We can not even look at them to
see what possibly could cause the problem. Please report all bugs you encounter
using that driver to Promise, not us.

Having said that, We are working on real, open source, drivers for the FastTrack
and so far, I can mount filesystems and read and write files with the driver I
made; so far it is RAID0 only though.
Comment 10 Andrew Powell 2001-05-11 04:39:46 EDT
I have the same promise problem as curtis, except I don't use the promise 
drivers at ALL for RH7.0, same hang after VPIDE, I have tried the following 
various kernel options:
ide=nodma
ide0=0xc000,0xc007,14 ide1=0xc0000,0xc00f,14 
ide0=0xc000,0xc007,14 ide1=0xc0000,0xc00f,14 ide2=none ide3=none

I have also compiled a version of the 2.4.3 kernel with the appropriate VIA ide 
drivers, and the same problem occurs.

The only solution to date has been to turn off the promise controller in the 
bios!  Which is not very good for the other OS' I use.

Thanks,
Andrew P.
BTW Config:
MSI 694D PRO AR - 3.4 BIOS, running Dual P3 800's, 256Mb ram
2x9.1GB IDE Drives on IDE0
1xHitatchi DVD Drive on IDE1 (Master)
2x20GB IDE Drives on Promise Controller (1 on each channel)
Initio U2W SCSI Controller
1x4.5 GB SCSI HDD
1xSCSI Yamaha CDRW
Comment 11 Arjan van de Ven 2001-05-11 04:43:00 EDT
powella@ozemail.com.au: could you try the 2.4.3-2.14.X (X >= 10) kernel
that is available from the rawhide directory?
Comment 12 baulv 2001-05-11 23:19:56 EDT
I have previously reported a similar problem with my Creative 36X CD-rom, that
hangs during install, then will not mount at all. I continued the install on my
Ricoh MP9129A. The 7.1 installer hung on the "blue screen" <do you have a driver
disc?> .
Later moving the 36x Creative CD-ROM to the Promise Ultra66 solved the problem.
I suppose the problem is with the kernel driver for the intel PllX4 ide-controller.
RH 7.0 or wolverine did not have this problem.


snip from /var/log/dmesg


Uniform Multi-Platform E-IDE driver Revision: 6.31
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
PIIX4: IDE controller on PCI bus 00 dev 39
PIIX4: chipset revision 1
PIIX4: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0xf000-0xf007, BIOS settings: hda:DMA, hdb:pio
    ide1: BM-DMA at 0xf008-0xf00f, BIOS settings: hdc:DMA, hdd:pio
PDC20262: IDE controller on PCI bus 00 dev 68
PCI: Found IRQ 12 for device 00:0d.0
PDC20262: chipset revision 1
PDC20262: not 100% native mode: will probe irqs later
PDC20262: (U)DMA Burst Bit ENABLED Primary PCI Mode Secondary PCI Mode.
    ide2: BM-DMA at 0xec00-0xec07, BIOS settings: hde:DMA, hdf:DMA
    ide3: BM-DMA at 0xec08-0xec0f, BIOS settings: hdg:pio, hdh:pio
hda: WDC AC35100L, ATA DISK drive
hdc: RICOH DVD/CDRW MP9120, ATAPI CD/DVD-ROM drive
hdg: CREATIVECD3630E, ATAPI CD/DVD-ROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
ide3 at 0xe400-0xe407,0xe802 on irq 12
hda: 10085040 sectors (5164 MB) w/256KiB Cache, CHS=627/255/63, UDMA(33)

Comment 13 baulv 2001-05-11 23:26:38 EDT
I experimented with setting PIO modes in BIOS for the creative 36x, didn't help.
the 33 MHz assumption is wron in my case as I run the PCI bus at 41 MHz. I did
not try to "normal-clock" the bus.
Comment 14 Andrew Powell 2001-05-14 07:34:29 EDT
arjanv: Many thanks for the solution. AP.
Comment 15 Andrew Powell 2001-05-24 03:38:02 EDT
arjanv:
I have just received my deluxe workstation 7.1CDs I gather that I am going to 
have the same problems, hence is there a workaround/suggested way to install 
without going throught all the dramas?

Thanks,
Andrew P.
Comment 16 Charis 2001-06-27 17:04:40 EDT
arjanv:I have exactly the same problems as medwards,with RH7.1.
The system is a Gateway PIII 850,with a 30 GB hd and a Promise 66 controler .I tried all the different boot options but nothing seems to work!Are there 
any new insights on the problem?
Comment 17 Need Real Name 2001-09-04 06:03:59 EDT
Hi

I have the same problem on 2 totaly different machines.
Tried the nodma option and they still hang.

Regards
Anthony
Comment 18 Andrew Powell 2001-09-04 07:16:13 EDT
Anthony,

Question: have you checked if your HDD's are connected as per Promise's 
recommendations, mine were not (in the end), 2 HDD's should be connected to the 
same channel, then everything works sweet with RH7.1.

Cheers,
AP
Comment 19 Oliver Schulze L. 2001-09-04 09:02:50 EDT
I have an ASUS A7V that comes with two IDE chipset: VIA and Promise.
It seems that my problem is with the VIA chipset and not the Promise.
So, now I have plugged all my drives to the Promise chipset and disabled
the VIA. This also speed up the boot process.

The problem now is that the Promise chipset boot only from a DOS bootable
CD(i.e. the WinXP evaluation CD) and not from a RH CD.

I still haven't try disabling the promise and plug all the drives to the VIA
chipset. This may be the solution on an A7V.
Comment 20 Need Real Name 2001-09-12 11:11:45 EDT
I experience the same problem, with an older system.  During a boot attempt, 
(for installation, using boot.img dated 4/9/01 3:37AM), my system also hangs at:

ide0 at <some address> on IRQ 14
ide2 at <some address> on IRQ 11

The relevant hardware:

FICA PT-2200 motherboard (running Pentium 166MMX)
     -has on-board IDE controller, which when used alone, has successfully
      accomodated various Linux installations
     -only connected device is a Primary/Master CD-RW

Promise Ultra100 controller
     -only connected device is a Primary/Master Quantum KA13.6 7200rpm drive
     -controller was necessary to break through 8.4GB limitation
     -happily supports Win98SE installation

     In addition to attempting RH7.1 installation, I have obtained a number of 
other boot-images, with the same results :-(

     I have used a number of Linux distributions since 1996 - hand-configuring 
X-servers and sendmail, etc.  But I'm baffled and dismayed by this current 
inability to install (particularly galling since Win98SE installed so 
effortlessly :-( ).

     -Gord
Comment 21 Need Real Name 2001-10-10 09:29:34 EDT
You are not alone !

My Hardware is :
- GIGABYTE GA-7DXR with AMD 761+686B AGPset
- Integrated Promise Ultra DMA RAID-1 (2x40 GB as RAID-1 array)
- IDE0 is connected to DVD player
Works fine with FastTrack driver from Promise and rh7.0. Raid-1 was installed 
as SDA. Under W98SE works find as SCSI RAID-1.

When installing rh7.1 with promise driver, linux also recognizes in addition to 
SDA the same RAID-1 array disks as HDE(IDE3) and HDG(IDE4). When doing the 
installation, the RAID-1 array has to be rebuild.
After some investigation I found, that I had to install and boot with the 
following parms (only IDE0 is used for DVD - disks are connected promise raid):
"ide1=0 ide2=0 ide3=0 ide4=0 ide5=0 ide6=0 ide7=0 ide8=0 ide9=0"
With this, only SDA is used and is working fine so far.

Without this parms, one RAID IDE is corrupted and I had to rebuild the array.

The final question is, how to manipulate the IDE detection, in order not to 
recognize HDE and HDG as single disks, but only SDA as with rh7.0?
Comment 22 Oliver Schulze L. 2001-10-11 13:27:44 EDT
The kernel that is installed after the instalation works fine with my Promise
ATA-100.
I think if RedHat release a new boot.img with the latest kernel, the problem
with be solved. They can also use the kernel image that is installed by
default in RH7.1 and it would work.

But right now, I think our only solution is to wait until RH7.2 :-(

Cheers
Oliver
Comment 23 oneway 2001-11-27 10:46:26 EST
Don't hold your breath, it does not work in RH7.2
Comment 24 Alan Cox 2003-06-06 08:00:37 EDT
We've done huge amounts of work on the IDE over errata and through 7.3 to 9.0. 
If any of you still have this problem with current Red Hat please re-open the
bug. Thanks

Note You need to log in before you can comment on or make changes to this bug.