Bug 38408 - XFree libs should contain the locale information
XFree libs should contain the locale information
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-30 12:48 EDT by Henning Schmiedehausen
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-01 03:44:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Henning Schmiedehausen 2001-04-30 12:48:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.19-1t i686)


The X Libraries need the locale files to do language specific conversions.

On my servers, I install only the XFree86-libs component to be sure, that
noone tries
to run a desktop on the servers, but I need some of the libs for certain
programs which
should open a remote display (namely emacs). You get annoying errors if
there are
no files in /usr/X11R6/lib/X11/locale

Reproducible: Always
Steps to Reproduce:
rpm -ql XFree86-libs | grep locale	

Actual Results:  e.g. emacs-X11 does not run without the whole XFree86
package installed.


the locale files are IMHO part of the library. They should be installed
with the libs
and not the main package
Comment 1 Mike A. Harris 2001-05-01 03:44:53 EDT
Agreed.  This is something we recently discovered, and discussed changing.
Unfortunately, it was too late in devel cycle to change.  I will try to make
the change happen soon though, as it makes total sense.

Thanks for bugzilla'ing it.  It'll keep it on my mind.  ;o)
Comment 2 Mike A. Harris 2001-05-04 02:25:30 EDT
Since the main XFree86 package contains this stuff, and it requires the
XFree86-libs package to be installed, it is safe for this to move to the
libs package without killing any dependancies.

Fixed in XFree86-4.0.3-13 in rawhide.  Should appear during next sync.

Note You need to log in before you can comment on or make changes to this bug.