Bug 38412 - GCJ crashes on "hello world"
GCJ crashes on "hello world"
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-30 13:29 EDT by Olivier Crête
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-30 14:22:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Hello World Source code (142 bytes, text/plain)
2001-04-30 13:30 EDT, Olivier Crête
no flags Details

  None (edit)
Description Olivier Crête 2001-04-30 13:29:42 EDT
GCJ crashes when trying to compile Hello World.... I would consider this a
"BAD"....
Comment 1 Olivier Crête 2001-04-30 13:30:27 EDT
Created attachment 16854 [details]
Hello World Source code
Comment 2 Jakub Jelinek 2001-04-30 14:22:24 EDT
Can you please be a little bit more specific?
I've tried
gcj -O2 -fmain=hello hello.java -o hello
./hello
and it worked just fine, similarly with a couple of other options
(-O0, -O2 -mcpu=i686, etc.),
gcj -C hello.java
does not crash either.
Comment 3 Olivier Crête 2001-04-30 14:30:35 EDT
Ahh, I didnt know about the -fmain= parameter....

What I did was...

[Tester@TesterBox Tester]$ gcj hello.java -o hello
/usr/lib/gcc-lib/i386-redhat-linux/2.96/../../../crt1.o: In function `_start':
/usr/lib/gcc-lib/i386-redhat-linux/2.96/../../../crt1.o(.text+0x18): undefined
reference to `main'
collect2: ld returned 1 exit status

The error message is not very informative to say the least...

Note You need to log in before you can comment on or make changes to this bug.