Bug 384231 - Skip broken option don't completely work
Skip broken option don't completely work
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
8
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-15 04:44 EST by Marco Maccaferri
Modified: 2014-01-21 18:00 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-11 01:40:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Marco Maccaferri 2007-11-15 04:44:39 EST
Description of problem:
Today's update showed a dependency issue (Missing Dependency: gecko-libs =
1.8.1.8 is needed by package yelp), so I've enable the skip-broken option with
"yum --skip-broken update", the initial dependecy check worked, but after
downloading the packages the transaction check failed with the gecko-libs
dependency.

Version-Release number of selected component (if applicable):
1.1.8-1.fc8

How reproducible:
Always

Steps to Reproduce:
1. Run "yum --skip-broken update" with today's updates
  
Actual results:
Still failing with the dependency checks.

Expected results:
The skip broken option should not bring in broken dependencies.
Comment 1 Tim Lauridsen 2007-11-15 08:44:56 EST
skip-broken is a plugin from yum-utils, so i have changed the component to
yum-utils.
the skip-broken is not catching all issue, it is only testing if each available
update can be depsolved without error alone, if not they are removed from the
transaction.
I am working on a better solution, by integrating the 'skip-broken' feature into
yum, instead of in a plugin, it will make it better but there is some weird
issues it can't detect because, they are first detected in the rpm test transaction.

Comment 2 Seth Vidal 2008-03-11 01:40:05 EDT
skip-broken has now been merged into yum for rawhide and F9. I'm going to close
this bug as all future bugs on it should be there

Note You need to log in before you can comment on or make changes to this bug.