Bug 38431 - pdftex included in tetex is outdated
pdftex included in tetex is outdated
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: tetex (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-30 14:21 EDT by clepple
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-11 10:15:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description clepple 2001-04-30 14:21:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0) <-- OK, 
you caught me :-)


The version of pdftex in the tetex package (the one included with RH 6.2, 
7.0 and 7.1) is 0.13d, which is getting outdated. The current version is 
somewhere around 0.14h, I think.

Including a new version would help reduce the number of FAQs on the pdftex 
lists (the answers to which usually end in "...upgrade to the latest 
version").

Since pdftex development moves much faster than plain TeX or LaTeX, it may 
be a good idea to split pdftex and pdflatex into a separate RPM (though I 
don't know much about the tetex distribution itself -- this may be asking 
for trouble if the rest of tetex gets upgraded).

Reproducible: Always
Steps to Reproduce:
1. pdftex -v => pdfTeX (Web2C 7.3.1) 3.14159-0.13d [...]	

A good point of reference for pdfTeX is 
http://www.tug.org/applications/pdftex/ - an archive of the mailing list 
is there, and in the archive there are several explanations of how to 
install new versions.

The other option might be to switch to MiKTeX.
Comment 1 Rex Dieter 2001-05-11 10:14:59 EDT
FYI, Switching to MikTeX is not an option as it is a Windows-only TeX
distribution.  )-:

Otherwise, either manually patch in the new pdftex into tetex or lobby tetex to
do it for us.
Comment 2 Tim Waugh 2001-06-04 18:26:07 EDT
I would rather have the upstream teTeX maintainer integrate it I think.

Presumably tetex-beta has a recent pdftex..

Note You need to log in before you can comment on or make changes to this bug.