Bug 384311 - Xorg cannot load synaptic module
Xorg cannot load synaptic module
Status: CLOSED DUPLICATE of bug 396891
Product: Fedora
Classification: Fedora
Component: synaptics (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-15 05:50 EST by Zdenek Kabelac
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-25 12:33:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
synaptics-0.14.6.diff (3.94 KB, patch)
2007-11-21 12:04 EST, Pierre Ossman
no flags Details | Diff

  None (edit)
Description Zdenek Kabelac 2007-11-15 05:50:58 EST
Description of problem:

Today's update of Xorg made synaptic driver unusable and I had to switch
to normal mouse driver (no fancy verical/horizonal scroll :( )
(I'll had to find mouse somewhere probably....)

(II) Loading /usr/lib64/xorg/modules/input//synaptics_drv.so
dlopen: /usr/lib64/xorg/modules/input//synaptics_drv.so: undefined symbol: miPoi
nterGetMotionEvents
(EE) Failed to load /usr/lib64/xorg/modules/input//synaptics_drv.so


Version-Release number of selected component (if applicable):

xorg-x11-server-Xorg-1.4.99.1-0.10.fc9
synaptics-0.14.4-11.fc8

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Panu Matilainen 2007-11-15 05:56:22 EST
synaptic != synaptics :) Reassigning...
Comment 2 Zdenek Kabelac 2007-11-15 06:02:42 EST
Upps sorry for this one :) - I've typed 'syn' in the windows - and synaptic
appeared at the bottom - and I'd no idea there are two such similar packages names..
Sure it belongs to Synaptics
Comment 3 Pierre Ossman 2007-11-18 14:29:03 EST
Seconded. This is a rather serious regression as it kills scrolling and tap
clicking. Please fix soon. :(
Comment 4 Pierre Ossman 2007-11-21 12:04:53 EST
Created attachment 266141 [details]
synaptics-0.14.6.diff

I found this patch in Suse's repo to get synaptics building for Xorg 7.4. You
also need to fix the Makefile to include /usr/include/pixman-1.
Comment 5 Alexandre Oliva 2007-11-25 12:33:58 EST

*** This bug has been marked as a duplicate of 396891 ***

Note You need to log in before you can comment on or make changes to this bug.