Bug 38450 - RFE: Installer halts when ftp site does not have needed file
RFE: Installer halts when ftp site does not have needed file
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-30 15:04 EDT by Philip Long
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-17 17:26:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philip Long 2001-04-30 15:04:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3 i686)


I had two seperate directories (iso loopback mounts) of seawolf1 and
seawolf2.  I started an ftpinstall off of the loopback on disc1.  It got to
tetex-fonts and hung for 30 min before I rebooted.  A timeout of some sort
on ftpinstalls (and a dialoge asking for another site/directory!)  would be
great! 


Reproducible: Didn't try
Comment 1 Brent Fox 2001-04-30 17:43:30 EDT
I'll mark this as an enhancement.  It's not really a bug since the fault is
really with the FTP site and not the installer, but this could be a nice feature
to add.
Comment 2 Ricky Ng-Adam 2001-05-26 01:55:23 EDT
I'd like to add the following because I'm not sure this is only a problem with some FTP servers timing out.  

I experienced the same problem with both a local intranet FTP server (RH6.2 with wu-ftpd-2.6.0-3) that seems to work fine even after the install hang.  

First time it  hanged at tetex, second time at emacs and third time (upon selecting less packages) at arp-utils.  ALT-Fing to the install console gives out 
repetitive "IO ERROR ftp error occurred getting [filename here] [errno ftp error] 550", which is very strange!

In one case, it gave that error at the very, very last package! Mucho frustrating.

The only way I could get it to install was to smallest install but useless install I could do (around 266 megs)... It seems to be related to how long the 
install takes!?

Either this is a bug with the wu-ftpd in 6.2 or the install for 7.1 as some problem.

But obviously, adding the proposed "feature" of timing out after X attemps and offering the opportunity of reconnecting to resume would solve a lots of 
problems.
Comment 3 Michael Fulbright 2001-09-17 17:26:47 EDT
Fixed in roswell.

Note You need to log in before you can comment on or make changes to this bug.