Bug 38455 - Oracle 8i (8.1.6/8.1.7) installer freezes
Oracle 8i (8.1.6/8.1.7) installer freezes
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: distribution (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-30 15:36 EDT by Daniel Hammer
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-05 02:54:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Hammer 2001-04-30 15:36:25 EDT
Cannot start Oracle 8i Java installer (which worked fine under RH 7.0)

Reproducible: Always
Steps to Reproduce:
After typing '/mnt/cdrom/install/linux/runInstaller' as Oracle-user or as
any other user with login shell it shows "Initializing Java Virtual Machine
from
../stage/Components/oracle.swd.jre/1.1.8/1/DataFiles/Expanded/linux/bin/jre.
Please wait..." but nothing more happens.
'ps faux' gives the following: 
user1    8883  0.0  1.8  8124 4572 ?  S  20:47 0:01 gnome-terminal
--use-factory --start-factory-server
user1    8886  0.0  0.2  1404  576 ?  S  20:47 0:00 \_gnome-pty-helper
user1    8887  0.0  0.6  2768 1660 pts/0  S 20:47   0:00  \_ bash
user1    9024  0.0  0.2  1404  508 pts/0    S    21:14   0:00 
\_/mnt/cdrom/install/linux/runInstaller
hombre    9025 94.2  0.9 37588 2292 pts/0  R 21:14  14:57 
\_/mnt/cdrom/stage/Components/oracle.swd.jre/1.1.8/1/DataFiles/Expanded/linux/bin/linux/native_th

I tried this under various window managers and made an 'strace' on it which
gives me:
... -- cut -- 
Please wait...
) = 131
fork()                                  = 9084
wait4(-1, 

The same thing happend when using a normal X-terminal.
Comment 1 Michael Fulbright 2001-04-30 17:40:49 EDT
Reassigning, this is now a Red Hat Linux install issue.
Comment 2 Brent Fox 2001-04-30 17:45:11 EDT
Correct that...*not* a Red Hat Linux install issue.
Comment 3 redhat-bugzilla 2001-05-21 09:00:54 EDT
I've run into the same or a related problem; I *have* followed the
release notes' instruction on using the compat libs. I can get two different
responses:
	If I run the installer in -silent mode, I get the errors described
	above

	If I run the installer without -silent mode, I get this:
SIGSEGV received at bfffe8b4 in
/var/local/archive/databases/oracle/dbms/8.1.7/Disk1/stage/Components/oracle.swd.jre/1.1.8/1/DataFiles/Expanded/linux/lib/linux/native_threads/libjava.so.
Processing terminated
	However, apparently something starts and spins in the background,
	chewing up all the CPU it gets.


Comment 4 Need Real Name 2001-06-05 02:54:15 EDT
Duplicate of 38372.
Find the fix documented here: http://www.thomasfly.com/Oranux/
Comment 5 Preston Brown 2001-06-05 17:01:10 EDT
It is also covered in the Red Hat Linux 7.1 release notes.

Note You need to log in before you can comment on or make changes to this bug.