Bug 384581 - The -h, --help in man page option badly formatted
The -h, --help in man page option badly formatted
Status: CLOSED DUPLICATE of bug 449743
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.5
All Linux
low Severity low
: ---
: ---
Assigned To: Pradeep Kilambi
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-15 08:40 EST by Jan Pazdziora
Modified: 2008-06-10 12:18 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-10 12:18:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2007-11-15 08:40:19 EST
Description of problem:

The -h, --help option in the up2date(8) man page is formatted within the
--arch=<arch> paragraph, not as the next paragraph.

Version-Release number of selected component (if applicable):

# rpm -q up2date
up2date-4.5.5-7.el4

How reproducible:

Deterministic.

Steps to Reproduce:
1. Run man up2date
2. Scroll down, to where the --arch=<arch> paragraph is.
  
Actual results:

       --undo If rpm transaction rollbacks are  enabled,
              attempt  to rollback the last rpm transac-
              tion. This feature is  deprecated  and  no
              longer functional.

       --arch=<arch>
              Force  a particular arch of package
              to be installed, instead of letting
              up2date choose.  -h, --help display
              help on command line arguments  and
              exit.

       -v, --verbose
              print  more  information about what
              Update Agent is doing.


Expected results:

       --undo If rpm transaction rollbacks are  enabled,
              attempt  to rollback the last rpm transac-
              tion. This feature is  deprecated  and  no
              longer functional.

       --arch=<arch>
              Force  a particular arch of package
              to be installed, instead of letting
              up2date choose.

       -h, --help display
              help on command line arguments  and
              exit.

       -v, --verbose
              print  more  information about what
              Update Agent is doing.


Additional info:

Also note that on 80 character wide terminal, the end of the man page gets narrower.
Comment 1 Jan Pazdziora 2007-11-15 08:42:56 EST
Looking into

zless /usr/share/man/man8/up2date.8.gz

the .TP is misplaced.

The extra .TP before --show-groups is another reason why the man page output
gets narrower and narrower.
Comment 2 RHEL Product and Program Management 2007-11-28 22:55:09 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 Jan Pazdziora 2008-06-10 12:18:32 EDT
It looks like this is being fixed in bug 449743 now.

*** This bug has been marked as a duplicate of 449743 ***

Note You need to log in before you can comment on or make changes to this bug.