Bug 384701 - RHEL4 xen-vnif module won't load in RHEL4u5 SMP (i686) guest , fails with unknown symbol __supported_pte_mask
RHEL4 xen-vnif module won't load in RHEL4u5 SMP (i686) guest , fails with unk...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
5.1
All Linux
high Severity medium
: ---
: ---
Assigned To: Don Dutile
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-15 09:47 EST by Jan Mark Holzer
Modified: 2008-07-02 15:37 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.1-10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-02 15:37:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Mark Holzer 2007-11-15 09:47:36 EST
Description of problem:

After installing the RHEL4 PV driver RPMS in a RHEL4u5 SMP guest from 
http://devserv.devel.redhat.com/~ddutile/pv-on-hvm/xenpv/rhel4/i686/
the xen-vnif module will fail load with an unknown symbol __supported_pte_mask
Actually the installation itself will already fail with a dependency check for
this symbol.

Version-Release number of selected component (if applicable):

RHEL4u5 SMP (UP is working fine)

How reproducible:

Install the RHEL4 SMP PV driver RPMS in a RHEL4u5 SMP guest and see the
installation fail.
 
Steps to Reproduce:
1. Copy the following RPMS from
   http://devserv.devel.redhat.com/~ddutile/pv-on-hvm/xenpv/rhel4/i686/
   kmod-xenpv-smp-0.1-1.el4.i686.rpm  
   xenpv-0.1-1.el4.i686.rpm     

2. Install them in a RHEL4u5 SMP guest
3. See the installation fail
  
Actual results:

[root@localhost ~]# rpm -ivh kmod-xenpv-smp-0.1-1.el4.i686.rpm
Preparing...                ########################################### [100%]
  1:kmod-xenpv-smp         ########################################### [100%]
WARNING: /lib/modules/2.6.9-55.ELsmp/extra/xenpv/0.1-1.el4/xennet.ko needs
unknown symbol __supported_pte_mask
WARNING: /lib/modules/2.6.9-55.ELsmp/extra/xenpv/0.1-1.el4/xen-vnif.ko needs
unknown symbol __supported_pte_mask

  or after the force installation of the kmod RPM the following message is
displayed in /var/log/messages when trying to load/insert the xen-vnif module

Nov 14 16:13:03 localhost kernel: xen_vnif: Unknown symbol __supported_pte_mask
Nov 14 16:12:28 localhost modprobe: FATAL: Error inserting xennet
(/lib/modules/2.6.9-55.ELsmp/extra/xenpv/0.1-1.el4/xennet.ko): Unknown symbol in
module, or unknown parameter (see dmesg)  
Nov 14 16:12:28 localhost modprobe: FATAL: Error inserting xennet
(/lib/modules/2.6.9-55.ELsmp/extra/xenpv/0.1-1.el4/xennet.ko): Unknown symbol in
module, or unknown parameter (see dmesg)  
Nov 14 16:15:27 localhost kernel: xen_vnif: Unknown symbol __supported_pte_mask


Expected results:

    Should be able to install RPMs and enable PV drivers for NIF and VBD

Additional info:

   The drivers work fine in a UP guest and the VBD driver also works
   for SMP

Note You need to log in before you can comment on or make changes to this bug.