Bug 385111 - impossible to make bugs public now
impossible to make bugs public now
Status: CLOSED WONTFIX
Product: Bugzilla
Classification: Community
Component: Creating/Changing Bugs (Show other bugs)
devel
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-15 12:47 EST by Máirín Duffy
Modified: 2013-06-23 22:51 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-26 15:31:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Máirín Duffy 2007-11-15 12:47:42 EST
I don't know when this change happened but:

It appears that a change has been recently made to bugzilla that results in bugs
getting into a state whereby it is impossible for the public comments in the bug
to be publicly accessible. This just caused me quite a bit of inconvenience when
working with some bugs.

The problem seems to stem from a new "enhancement" to the bug "groups" system.
Depending on how your account is bugzilla is set up, you are the member of
particular 'groups'. Some of these groups are:

- Red Hat Development
- Red Hat Network Engineering
- Red Hat Network Product Management
- Red Hat Quality Assurance

The problem surfaces when the checkboxes for a group to which you are not a
member end up getting checked off. I am not sure of all of the conditions that
lead to a bug being added to a group. But the problem is that, for example, if I
am only a member of the 'Red Hat Network Engineering' group, and the bug somehow
gets added to the 'Red Hat Quality Assurance' group, there is no possible way
that I can make that bug public because it is part of a group I am not part of,
so I cannot remove the bug's alignment to that group thus I can never make that
bug public.

I seriously doubt there are many accounts in bugzilla that have access to every
single group in bugzilla, so this change has effectively made making a bug
public rather impossible.

See, even though our bugzilla has this simple public / private comment system,
that apparently is not enough and two conditions have to be present for a given
bug comment to be visible to a customer:

- ALL group flags must be unchecked
- Only comments whose 'private' checkbox is unchecked will be visible to the
customer

If any single group flag is checked off, even if there are comments marked as
public in the bug, THE ENTIRE BUG will not be accessible by a customer.

None of the Red Hat Network, Red Hat Network Satellite, and Red Hat Network
Proxy groups appear to assign bug membership to groups by default, thankfully. I
am not sure how my bug got into the state that it was added to these groups, but
I am pretty upset about it. The only workaround I can think of is to clone the
bug with no group memberships and delete the old one but maybe cloning preserves
the group memberships... sigh. This is a lot of unnecessary work!

I think it is important that whenever possible we allow bugs or at least
portions of bugs to be accessible by our customers and the public. Customers
*do* look through bugzilla to see if others have reported issues they are
running into and this can sometimes result in the customer finding a solution to
a problem or getting more details about the bug they are experiencing and
when/how it might get fixed and workarounds! It is to our benefit that customers
can say "me too" and give additional details surrounding a bug rather than
filing yet another duplicate bug that may likely get lost in the fray, as it is
to our benefit that customers are able to discover help and workarounds on their
own and avoid a call to support.
Comment 1 David Lawrence 2008-11-26 15:31:15 EST
Unfortunately this is a function of Bugzilla design. The best to do in these cases is to ask the person who added the additional group to remove the check box. They may have had a reason to add the additional permission in the first place. Also it is not possible to make portions of the bug public and others not. It is either all public or all private (if the viewer is not in any of the groups checked).

Note You need to log in before you can comment on or make changes to this bug.