This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 385261 - wodim and dual-layer DVDs
wodim and dual-layer DVDs
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: cdrkit (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-15 13:53 EST by Ignacio Vazquez-Abrams
Modified: 2009-01-24 18:02 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-16 04:45:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ignacio Vazquez-Abrams 2007-11-15 13:53:44 EST
wodim won't allow me to burn DVD+R-DLs. Tried with 3 disks. Observe:

[ignacio@ignacio jigdo]$ ls -l Fedora-8-i386-Everything-DVD-DL1.iso
-rw-rw-r-- 1 ignacio ignacio 8979083264 2007-11-15 13:08
Fedora-8-i386-Everything-DVD-DL1.iso

[ignacio@ignacio jigdo]$ file Fedora-8-i386-Everything-DVD-DL1.iso
Fedora-8-i386-Everything-DVD-DL1.iso: ISO 9660 CD-ROM filesystem data UDF
filesystem data (unknown version, id 'NSR01') 'F-8 i386 Everything DVD-DL1    '
(bootable)

[ignacio@ignacio jigdo]$ wodim -v -dao Fedora-8-i386-Everything-DVD-DL1.iso
TOC Type: 1 = CD-ROM
wodim: Operation not permitted. Warning: Cannot raise RLIMIT_MEMLOCK
limits.Device was not specified. Trying to find an appropriate drive...
Looking for a DVD-R drive to store 8563.12 MiB...
Detected DVD-R drive: /dev/dvdrw
Using /dev/cdrom of unknown capabilities
scsidev: '/dev/cdrom'
devname: '/dev/cdrom'
scsibus: -2 target: -2 lun: -2
Linux sg driver version: 3.5.27
Wodim version: 1.1.6
SCSI buffer size: 64512
Device type    : Removable CD-ROM
Version        : 5
Response Format: 2
Capabilities   : 
Vendor_info    : 'HL-DT-ST'
Identification : 'DVD-RAM GSA-H55L'
Revision       : '1.00'
Device seems to be: Generic mmc2 DVD-R/DVD-RW.
Current: 0x002B (DVD+R/DL)
Profile: 0x0012 (DVD-RAM) 
Profile: 0x002B (DVD+R/DL) (current)
Profile: 0x001B (DVD+R) 
Profile: 0x001A (DVD+RW) 
Profile: 0x0016 (DVD-R/DL layer jump recording) 
Profile: 0x0015 (DVD-R/DL sequential recording) 
Profile: 0x0014 (DVD-RW sequential recording) 
Profile: 0x0013 (DVD-RW restricted overwrite) 
Profile: 0x0011 (DVD-R sequential recording) 
Profile: 0x0010 (DVD-ROM) 
Profile: 0x000A (CD-RW) 
Profile: 0x0009 (CD-R) 
Profile: 0x0008 (CD-ROM) 
Profile: 0x0002 (Removable disk) 
Using generic SCSI-3/mmc DVD-R(W) driver (mmc_mdvd).
Driver flags   : SWABAUDIO BURNFREE 
Supported modes: PACKET SAO
Drive buf size : 1409024 = 1376 KB
Beginning DMA speed test. Set CDR_NODMATEST environment variable if device
communication breaks or freezes immediately after that.
Drive DMA Speed: 109342 kB/s 621x CD 78x DVD
FIFO size      : 4194304 = 4096 KB
Track 01: data  8563 MB        
Total size:     9834 MB (974:17.57) = 4384318 sectors
Lout start:     9834 MB (974:19/43) = 4384318 sectors
Current Secsize: 2048
HINT: use dvd+rw-mediainfo from dvd+rw-tools for information extraction.
Blocks total: 4173824 Blocks current: 4173824 Blocks remaining: -210494
wodim: WARNING: Data may not fit on current disk.
wodim: Notice: Most recorders cannot write CD's >= 90 minutes.
wodim: Notice: Use -ignsize option to allow >= 90 minutes.
wodim: Notice: Use -overburn option to write more than the official disk capacity.
wodim: Notice: Most CD-writers do overburning only on SAO or RAW mode.

[ignacio@ignacio jigdo]$ wodim -v -ignsize -dao Fedora-8-i386-Everything-DVD-DL1.iso
TOC Type: 1 = CD-ROM
wodim: Operation not permitted. Warning: Cannot raise RLIMIT_MEMLOCK
limits.Device was not specified. Trying to find an appropriate drive...
Looking for a DVD-R drive to store 8563.12 MiB...
Detected DVD-R drive: /dev/dvdrw
Using /dev/cdrom of unknown capabilities
scsidev: '/dev/cdrom'
devname: '/dev/cdrom'
scsibus: -2 target: -2 lun: -2
Linux sg driver version: 3.5.27
Wodim version: 1.1.6
SCSI buffer size: 64512
Device type    : Removable CD-ROM
Version        : 5
Response Format: 2
Capabilities   : 
Vendor_info    : 'HL-DT-ST'
Identification : 'DVD-RAM GSA-H55L'
Revision       : '1.00'
Device seems to be: Generic mmc2 DVD-R/DVD-RW.
Current: 0x002B (DVD+R/DL)
Profile: 0x0012 (DVD-RAM) 
Profile: 0x002B (DVD+R/DL) (current)
Profile: 0x001B (DVD+R) 
Profile: 0x001A (DVD+RW) 
Profile: 0x0016 (DVD-R/DL layer jump recording) 
Profile: 0x0015 (DVD-R/DL sequential recording) 
Profile: 0x0014 (DVD-RW sequential recording) 
Profile: 0x0013 (DVD-RW restricted overwrite) 
Profile: 0x0011 (DVD-R sequential recording) 
Profile: 0x0010 (DVD-ROM) 
Profile: 0x000A (CD-RW) 
Profile: 0x0009 (CD-R) 
Profile: 0x0008 (CD-ROM) 
Profile: 0x0002 (Removable disk) 
Using generic SCSI-3/mmc DVD-R(W) driver (mmc_mdvd).
Driver flags   : SWABAUDIO BURNFREE 
Supported modes: PACKET SAO
Drive buf size : 1409024 = 1376 KB
Beginning DMA speed test. Set CDR_NODMATEST environment variable if device
communication breaks or freezes immediately after that.
Drive DMA Speed: 96286 kB/s 547x CD 69x DVD
FIFO size      : 4194304 = 4096 KB
Track 01: data  8563 MB        
Total size:     9834 MB (974:17.57) = 4384318 sectors
Lout start:     9834 MB (974:19/43) = 4384318 sectors
Current Secsize: 2048
HINT: use dvd+rw-mediainfo from dvd+rw-tools for information extraction.
Blocks total: 4173824 Blocks current: 4173824 Blocks remaining: -210494
wodim: WARNING: Data may not fit on current disk.
wodim: Notice: Overburning active. Trying to write more than the official disk
capacity.
Speed set to 5540 KB/s
Starting to write CD/DVD at speed   4.0 in real SAO mode for single session.
Last chance to quit, starting real write in    0 seconds. Operation starts.
Preparing middle zone location for this DVD+R dual layer disc
dvd_dual_layer_split: read_dvd_structure returns invalid data
Waiting for reader process to fill input buffer ... input buffer ready.
Errno: 5 (Input/output error), reserve track scsi sendcmd: no error
CDB:  53 00 00 00 00 00 42 E6 3E 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 70 00 05 00 00 00 00 0E 00 00 00 00 24 00 00 00
Sense Key: 0x5 Illegal Request, Segment 0
Sense Code: 0x24 Qual 0x00 (invalid field in cdb) Fru 0x0
Sense flags: Blk 0 (not valid) 
cmd finished after 0.021s timeout 200s
wodim: Cannot open new session.
Writing  time:    0.064s
wodim: fifo had 64 puts and 0 gets.
wodim: fifo was 0 times empty and 0 times full, min fill was 100%.

[ignacio@ignacio jigdo]$ dvd+rw-mediainfo /dev/sr0
INQUIRY:                [HL-DT-ST][DVD-RAM GSA-H55L][1.00]
GET [CURRENT] CONFIGURATION:
 Mounted Media:         2Bh, DVD+R Double Layer
 Media ID:              RITEK/D01
 Speed Descriptor#0:    00/4173823 R@8.0x1385=11080KB/s W@4.0x1385=5540KB/s
READ DVD STRUCTURE[#0h]:
 Media Book Type:       00h, DVD-ROM book [revision 0]
 Legacy lead-out at:    2086912*2KB=4273995776
DVD+R DOUBLE LAYER BOUNDARY INFORMATION:
 L0 Data Zone Capacity: 2086912*2KB, can still be set
READ DISC INFORMATION:
 Disc status:           blank
 Number of Sessions:    1
 State of Last Session: empty
 "Next" Track:          1
 Number of Tracks:      1
READ TRACK INFORMATION[#1]:
 Track State:           blank
 Track Start Address:   0*2KB
 Next Writable Address: 0*2KB
 Free Blocks:           4173824*2KB
 Track Size:            4173824*2KB
READ CAPACITY:          0*2048=0
Comment 1 Ignacio Vazquez-Abrams 2007-11-15 15:43:19 EST
Here's a similar report from debburn-devel:

http://lists.alioth.debian.org/pipermail/debburn-devel/2007-September/000468.html

growisofs also seems to work here as well.
Comment 2 Harald Hoyer 2007-11-16 04:45:40 EST
Well, then it is reported upstream.

You may use growisofs in the meantime instread of wodim.
Comment 3 Harald Hoyer 2007-11-16 04:46:58 EST
Total size:     9834 MB (974:17.57) = 4384318 sectors
Blocks total: 4173824 Blocks current: 4173824 Blocks remaining: -210494

Hmm, wodim thinks the image is too big.. strange
Comment 4 Ignacio Vazquez-Abrams 2007-11-16 07:10:43 EST
> Hmm, wodim thinks the image is too big.. strange

It was, but don't worry about that. Even growisofs choked on it eventually.
Comment 5 Jörg Schilling 2009-01-24 18:02:57 EST
Wodim has no proper DVD support, I recommend you to 
upgrade to recent original software from:

ftp://ftp.berlios.de/pub/cdrecord/alpha/

Note You need to log in before you can comment on or make changes to this bug.