Bug 385981 - add symvers file to /boot for 4.5 zstream kernels.
add symvers file to /boot for 4.5 zstream kernels.
Status: CLOSED DUPLICATE of bug 400851
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Vitaly Mayatskikh
Martin Jenner
: ZStream
Depends On:
  Show dependency treegraph
Reported: 2007-11-15 18:34 EST by Jon Masters
Modified: 2008-02-06 09:36 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-02-06 09:36:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
symvers patch backport from RHEL5 (2.43 KB, patch)
2007-12-18 01:18 EST, Jon Masters
no flags Details | Diff

  None (edit)
Description Jon Masters 2007-11-15 18:34:29 EST
Description of problem:

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 Jon Masters 2007-11-15 18:36:32 EST
Description of problem:

RHEL5 (and RHEL4.6) introduces a symvers file in /boot that is used by the
external module packaging infrastructure in order to determine whether a third
party module is compatible with a given kernel. This should be added in future
zstream kernels for RHEL4.5, and so on.

The patch is trivial, it's already in RHEL4.6 and it's a couple of lines of
backport. I'll attach that to this BZ.

Comment 5 Jon Masters 2007-12-18 01:18:12 EST
Created attachment 289854 [details]
symvers patch backport from RHEL5
Comment 6 RHEL Product and Program Management 2008-01-02 17:26:14 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
Comment 9 Vitaly Mayatskikh 2008-02-06 09:36:43 EST

*** This bug has been marked as a duplicate of 400851 ***

Note You need to log in before you can comment on or make changes to this bug.