Bug 38636 - parsing DTD gives
Summary: parsing DTD gives
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: psgml   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-01 19:15 UTC by Ed Bailey
Modified: 2007-04-18 16:32 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-01 19:15:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ed Bailey 2001-05-01 19:15:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.19-7.0.1enterprise i686; en-US;
0.8.1) Gecko/20010430


psgml allows you to parse a document's DTD, and save it to a file.  This
"pre-parsed" DTD can then be used to work with file that might not have a
DTD definition line at the top of the file.

This has worked since Red Hat Linux 6.1; however, now the error message
"External entity xxxx not found" appears ("xxxx" being "BOOK" where the
document is a DocBook book-type document)


Reproducible: Always
Steps to Reproduce:
1.Open a Docbook 3.1 document (with the DTD definition line at the top) in
emacs.

2.Either type C-c C-p, or select the "Parse DTD" menu entry from the "DTD"
menu.

3.An SGML LOG buffer will appear with the warning message:

External entity BOOK not found
  Public identifier -//OASIS//DTD DocBook V3.1/EN

	

Actual Results:  psgml-mode will not understand the document's structure. 
In other words, if you use psgml-mode to enter a tag, it will not have a
list of tags that are valid for the current point in the file.

(Note: I just played with it some more, and psgml-mode cannot be made to
work under any circumstances.  It used to be that it would essentially do
an automatic parse of the DTD behind the scenes (such as when you went to
enter a new tag).  Now psgml-mode fails with the same error message as
outlined above.)

Expected Results:  psgml-mode should have parsed the DTD, and then allowed
me to save the pre-parsed DTD in a file.  This file should then be readable
by psgml-mode in subsequent editing sessions to give psgml the necessary
information to suggest the appropriate tags in a given document.

Unfortunately, this greatly hampers our ability to work with SGML documents
under 7.1, so I'm grading this as high severity.

Comment 1 Ed Bailey 2001-05-02 14:24:51 UTC
My bad -- I was setting SGML_CATALOG_FILES in my .bashrc *and* doing a setq of
sgml-catalog-files in my .emacs -- and I was only changing SGML_CATALOG_FILES... 

Sorry for the mixup...



Note You need to log in before you can comment on or make changes to this bug.