Bug 38648 - voodoo5 no 3d when running tuxracer or tribes2
voodoo5 no 3d when running tuxracer or tribes2
Status: CLOSED DUPLICATE of bug 36158
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-01 17:03 EDT by Charles R. Tersteeg
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-04 00:34:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Charles R. Tersteeg 2001-05-01 17:03:30 EDT
the resulting line after typing /usr/X11R6/bin/glxinfo

gd error (glide): gd error (glide): grSstSelect: non-existent SSTgd error
(glide): grSstSelect: non-existent SSTSegmentation fault (core dumped)

i found this page for reference:
http://www.linux.sarang.net/ftp/pub/mirror/xwindow/XFree86/4.0.2/doc/HTML/DRI10.html

am i missing something to enable opengl on a workstation installation of rh7.1?

I have tried the default X-server XFree86-4.0.3-5 and the latest rawhide
XFree86-4.0.3-10

Reproduceable everytime:
1. type /usr/X11R6/bin/glxinfo
2. type tribes2
3. type tuxracer

all three produce same error over and over

Actual results:

gd error (glide): gd error (glide): grSstSelect: non-existent SSTgd error
(glide): grSstSelect: non-existent SSTSegmentation fault (core dumped)

and a core file

Expected Results:
the opengl game/app would run

Additional Info:
CPU PIII(x2) 933
running SMP kernel
512MB RAM
6GB HD on /
20GB HD on /home
3DFX Voodoo 5500
Sound Blaster Live!
3 button USB Mouse - BoomSlang2000
Haupauge PCI - TV/Radio Tuner
Serial PCI - 2 serial and 1 parallel
Standard setup - Ximain Gnome 1.4 also installed but should not affect this.
Comment 1 Mike A. Harris 2001-05-02 17:05:36 EDT
Workaround:
cd /usr/lib
rm libglide3-so.3.10.0
ln -s libglide3-so.3.10.0 glide/libglide3-v5.so

You *must* use 16 bit depth to do 3D, and if you have problems, lower your
resolution down.
Comment 2 Charles R. Tersteeg 2001-05-03 01:18:19 EDT
Thanks for the workaround.  The games run but no video to screen, i blindly exit
the game.  Sounds nice but can see.

before workaround:
[root@moon-wolf lib]# ls libglide3.so* -l
lrwxrwxrwx    1 root     root           19 May  1 17:09 libglide3.so ->
libglide3.so.3.10.0
lrwxrwxrwx    1 root     root           19 May  1 17:09 libglide3.so.3 ->
libglide3.so.3.10.0
lrwxrwxrwx    1 root     root           22 May  1 17:09 libglide3.so.3.10.0 ->
glide3/libglide3-v3.so

what i did:
[root@moon-wolf lib]# rm libglide3.so.3.10.0 
rm: remove ?libglide3.so.3.10.0?? y
[root@moon-wolf lib]# ln -s glide3/libglide3-v5.so libglide3.so.3.10.0

what it is now:
[root@moon-wolf lib]# ls libglide3.so* -l
lrwxrwxrwx    1 root     root           19 May  1 17:09 libglide3.so ->
libglide3.so.3.10.0
lrwxrwxrwx    1 root     root           19 May  1 17:09 libglide3.so.3 ->
libglide3.so.3.10.0
lrwxrwxrwx    1 root     root           22 May  3 00:12 libglide3.so.3.10.0 ->
glide3/libglide3-v5.so

I tried it in 1600x1200 and 640x480 with the same results.  please advise. 
thanks for the quick help.
Comment 3 Charles R. Tersteeg 2001-05-03 01:19:46 EDT
note:  i'm using XfFree86-4.0.3-5 should i be using latest rawhide for
workaround? XFree86-4.0.3-10?
Comment 4 Charles R. Tersteeg 2001-05-04 00:33:56 EDT
I looked at bug #38869 and it is the same as this one.  I also tried the file
from dri, and tuxracer now works but I still get a black screen with tribes2. 
Any suggestions?
Comment 5 Mike A. Harris 2001-05-04 03:52:28 EDT

*** This bug has been marked as a duplicate of 36158 ***

Note You need to log in before you can comment on or make changes to this bug.