Bug 386551 - Undesirable /etc/xdg/autostart of bluetooth-applet now honoured by KDE
Undesirable /etc/xdg/autostart of bluetooth-applet now honoured by KDE
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: bluez-gnome (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-16 05:03 EST by Miles Sabin
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-16 06:15:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miles Sabin 2007-11-16 05:03:33 EST
Description of problem:

A recent change in the KDE packages (see mention in
https://bugzilla.redhat.com/show_bug.cgi?id=247284) means that all KDE sessions
start the Gnome bluetooth applet whether it's wanted or not. Removing
bluez-gnome is not currently an option because it is depended on by bluez-utils.
In any case, the choice of desktop-specific applets should not be determined by
system-wide configuration.

Version-Release number of selected component (if applicable):
bluez-gnome-0.8-2.fc7

How reproducible:
Always

Steps to Reproduce:
1. Install bluez-utils
2. Log in to a KDE desktop
3.
  
Actual results:
bluetooth-applet is autostarted.

Expected results:
bluetooth-applet should not be autostarted unless configured to do so by the
logged in user.

Additional info:
Comment 1 Bastien Nocera 2007-11-16 06:15:57 EST
(In reply to comment #0)
> Description of problem:
> 
> A recent change in the KDE packages (see mention in
> https://bugzilla.redhat.com/show_bug.cgi?id=247284) means that all KDE sessions
> start the Gnome bluetooth applet whether it's wanted or not. Removing
> bluez-gnome is not currently an option because it is depended on by bluez-utils.

I'm sure you can remove bluez-gnome from the startup in some preferences
dialogue. GNOME has one with tickboxes in the Session preferences.

> In any case, the choice of desktop-specific applets should not be determined by
> system-wide configuration.

It's a default, you should be able to disable it in whatever preference dialogue
KDE provides for that. Also, the bluetooth-applet running is necessary on F7 for
KDE to have a working pairing agent, as the shipped version of KDE Bluetooth
doesn't work with the more recent hcid D-Bus API.

This means that Bluetooth works (more or less) out of the box, and doesn't need
to be unbroken. Feel free to disable it yourself.

Please reopen this bug against KDE if it doesn't provide with an option to
disable starting up the applet.

Note You need to log in before you can comment on or make changes to this bug.