Bug 386851 - vpn icon sometimes stays after vpn disconnects
vpn icon sometimes stays after vpn disconnects
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager-vpnc (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-16 09:22 EST by Dan Winship
Modified: 2008-11-17 09:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-17 09:10:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Winship 2007-11-16 09:22:00 EST
Sometimes after I disconnect the VPN, the lock icon stays there, even though
the menu state shows that I'm no longer connected to the VPN.

~/.xsession-errors doesn't show anything
Comment 1 Dan Winship 2007-12-13 13:42:19 EST
Usually after this happens I kill and restart nm-applet to get the icon back
to normal.

This morning I came in and disocovered that although the icon showed I was
connected to the vpn, the menu showed (correctly) that I wasn't. So I reconnected
via the menu, and got the swirly vpn-connecting icon, and then... the icon
changed to the "no network" icon (computers with red X). Zany.

(I wasn't really paying that much attention when I connected, so it's possible
that the connecting animation was messed up slightly too and I just didn't notice.)
Comment 2 Denis Leroy 2007-12-13 16:32:54 EST
I've noticed this behavior multiple times too.
Comment 3 Dan Winship 2008-02-13 09:53:09 EST
Seems to be fixed now?
Comment 4 David Juran 2008-02-19 05:31:08 EST
No, I've seen this today with NetworkManager-vpnc-0.7.0-0.6.3.svn3109.fc8
Comment 5 Dan Winship 2008-02-19 08:15:35 EST
Yeah, I'm seeing it again now too. Weird. It went away for a week, and I don't
think I was doing anything different than I normally do...
Comment 6 Denis Leroy 2008-02-19 10:00:59 EST
I occasionally see the opposite effect: the icon goes back to normal even though
my VPN connection is still active...
Comment 7 Dan Williams 2008-11-17 09:10:18 EST
Pretty sure this hasn't been seen in a long time.

Note You need to log in before you can comment on or make changes to this bug.