Bug 38713 - kdm corupts MBR and (probably) partition tables
kdm corupts MBR and (probably) partition tables
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-02 02:28 EDT by Kenneth Corbin
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-02 02:28:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kenneth Corbin 2001-05-02 02:28:31 EDT
I have Powerquest Boot Magic installed on my MBR.   The first time I asked
kdm to reboot the system, it gave me a list of the partition I could reboot
do from the lilo.conf file.   But simply rebooting back to the standard MBR
did not appear to be an option.   After selecting a DOS paritition that I
really wanted to, the system rebooted and then hung.  After a ctl-alt-del
reboot, I ended up booting strait to the linux partition, Boot Magic no
longer was functioning.

After several attempts to put things back together, and reinstalling Boot
Magic, the (DOS) BM configuration program still isn't working correctly,
and there some as yet undetermined amount of damage to my disks partition
tables.   I'm working with Powerquest support to try to determine what is
broken and whether it can be recovered.   In the meantime I would warn
people not to use the kdm reboot feature under any circumstances.
Comment 1 Bernhard Rosenkraenzer 2001-05-02 04:50:49 EDT
If you aren't using LILO, don't ask kdm to configure LILO for you.

Open kcontrol, go System > Login Manager > Sessions, then deselect "LILO > 
Show boot options".

You'll lose the feature of being able to specify which OS/kernel you want to 
boot next time around because this doesn't work with any non-LILO boot 
managers.


Note You need to log in before you can comment on or make changes to this bug.