Bug 38715 - RPM does not provide useful error message for corrupted packages
RPM does not provide useful error message for corrupted packages
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-02 04:14 EDT by Mike MacCana
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-02 04:25:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike MacCana 2001-05-02 04:14:11 EDT
The following error message is produced when upgrading or installing a 
corrupted package in verbose mode:

"error: /tmp/kdelibs-devel-2.1.2-1.i386.rpm cannot be installed"

This is not an explanation, not particularly verbose, and (unlike all 
other rpm error messages) contains no useful information for an 
administrator. The only reason given for failed installed is that, well, 
it failed.

"error: reading /tmp/kdelibs-devel-2.1.2-1.i386.rpm. The package may be 
corrupt - please acquire another copy"

I have marked this as high severity because the error message requires 
unnecessary diagnosis on behalf of administrators updating their system 
and documentation as to what this error mesage actually means is not 
often available. Furthermore, its often quite difficult to discover if no 
md5sums are provided with the packages. 

Thanks, 

Mike
Comment 1 Mike MacCana 2001-05-02 04:25:00 EDT
A line of text seems to be missing from the above:

"error: reading /tmp/kdelibs-devel-2.1.2-1.i386.rpm. The package may be 
 corrupt - please acquire another copy"

...would be a more useful error message. 

Thanks,

Mike
Comment 2 Jeff Johnson 2001-05-06 09:34:17 EDT
Yes, the failure to install message is incredibly obscure. This
has been improved in rpm-4.0.3 by printing out the details
for the failure, but the Right Thing To Do is to rip the check
out entirely, and integrate the MD5/SHA1 checks available
with rpm -K into every package header read. That's a different
problem than changing the text of an error message however, so
I'm gonna resolve this bug to RAWHIDE.

Since there are failure modes other than package corruption,
suggesting acquiring a different copy is not the best solution.

Note You need to log in before you can comment on or make changes to this bug.