Bug 387151 - Copying from USB drive to SATA causing hangups
Copying from USB drive to SATA causing hangups
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-16 11:29 EST by David Florence
Modified: 2008-02-14 14:46 EST (History)
5 users (show)

See Also:
Fixed In Version: 2.6.23.14-115.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-13 18:40:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Errors reported in System Log (6.00 KB, text/plain)
2007-11-16 11:30 EST, David Florence
no flags Details
log file for alienware laptop Hang (54.80 KB, application/octet-stream)
2007-11-28 12:53 EST, James Eniti
no flags Details

  None (edit)
Description David Florence 2007-11-16 11:29:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.9) Gecko/20071105 Fedora/2.0.0.9-1.fc8 Firefox/2.0.0.9

Description of problem:
Attempting to copy a backup from a 500GB USB Drive to an SATA drive, causes USB drive to fail with I/O errors and the keyboard and mouse to freeze.

Will not generate deguginfo, must hit reset button to reboot.

Version-Release number of selected component (if applicable):
kernel version: 2.6.23.1-49.fc8

How reproducible:
Always


Steps to Reproduce:
1.Power on USB device
2.Browse folders
3.Drag and Drop, or Cut and Paste

Actual Results:
Copying will be successfully initially, then the USB drive will hang, or the mouse and keyboard will freeze.

Expected Results:
Should copy files to another device without hanging system.

Additional info:
Have reinstalled a fresh FC8
Whether attempting the copy process, before any updates or after updates, the problem persists.
Comment 1 David Florence 2007-11-16 11:30:58 EST
Created attachment 261441 [details]
Errors reported in System Log
Comment 2 David Zeuthen 2007-11-16 12:11:34 EST
Looks like a kernel bug to me
Comment 3 Chuck Ebbert 2007-11-16 12:36:44 EST
Nov 16 07:27:58 localhost hald: mounted /dev/sde1 on behalf of uid 500
Nov 16 08:02:45 localhost kernel: usb 1-1: USB disconnect, address 4
Comment 4 David Zeuthen 2007-11-16 12:44:08 EST
(In reply to comment #3)
> Nov 16 07:27:58 localhost hald: mounted /dev/sde1 on behalf of uid 500
> Nov 16 08:02:45 localhost kernel: usb 1-1: USB disconnect, address 4

Uhm, yes. And?
Comment 5 David Zeuthen 2007-11-16 12:47:04 EST
(In reply to comment #4)
> (In reply to comment #3)
> > Nov 16 07:27:58 localhost hald: mounted /dev/sde1 on behalf of uid 500
> > Nov 16 08:02:45 localhost kernel: usb 1-1: USB disconnect, address 4
> 
> Uhm, yes. And?

Oh, sorry, I missed that you reassigned to our USB guru Pete.
Comment 6 Pete Zaitcev 2007-11-16 14:10:30 EST
Yes, I hear and obey. However, this is just a sudden disconnect. I highly
doubt that Linux (including both HAL and kernel) did anything to precipitate
it. It's just a duff enclosure, most likely the power.
Comment 7 James Eniti 2007-11-28 11:59:07 EST
I have an Alienware with something that looks like this problem
It is reproduced by heavy WRITE to the HDD (SATA) 
I found 2 ways to hit it, gnome-pilot backup of Tungsten E2 and tar restore of
mail dir (tar cf - mail| (cd ~/.evolution; tar xf - ))
The tar pipe hangs the system in about 14 sec.
Hardware details:
lspci
00:00.0 Host bridge: VIA Technologies, Inc. K8T890 Host Bridge
00:00.1 Host bridge: VIA Technologies, Inc. K8T890 Host Bridge
00:00.2 Host bridge: VIA Technologies, Inc. K8T890 Host Bridge
00:00.3 Host bridge: VIA Technologies, Inc. K8T890 Host Bridge
00:00.4 Host bridge: VIA Technologies, Inc. K8T890 Host Bridge
00:00.5 PIC: VIA Technologies, Inc. K8T890 I/O APIC Interrupt Controller
00:00.7 Host bridge: VIA Technologies, Inc. K8T890 Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI bridge [K8T800/K8T890 South]
00:02.0 PCI bridge: VIA Technologies, Inc. K8T890 PCI to PCI Bridge Controller
00:03.0 PCI bridge: VIA Technologies, Inc. K8T890 PCI to PCI Bridge Controller
00:03.2 PCI bridge: VIA Technologies, Inc. K8T890 PCI to PCI Bridge Controller
00:05.0 CardBus bridge: ENE Technology Inc CB1410 Cardbus Controller (rev 01)
00:06.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A IEEE-1394a-2000
Controller (PHY/Link)
00:08.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit
Ethernet (rev 10)
00:0a.0 Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC
(rev 01)
00:0f.0 RAID bus controller: VIA Technologies, Inc. VIA VT6420 SATA RAID
Controller (rev 80)
00:0f.1 IDE interface: VIA Technologies, Inc.
VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 81)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 81)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 81)
00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 81)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8237 ISA bridge
[KT600/K8T800/K8T890 South]
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237
AC97 Audio Controller (rev 60)
00:11.6 Communication controller: VIA Technologies, Inc. AC'97 Modem Controller
(rev 80)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM
Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
Miscellaneous Control
02:00.0 VGA compatible controller: nVidia Corporation GeForce Go 7900 GTX (rev
a1)/dev/sda:

 Model=ST910021AS                              , FwRev=3.04    , SerialNo=     
      3MH06806
 Config={ HardSect NotMFM HdSw>15uSec Fixed DTR>10Mbs RotSpdTol>.5% }
 RawCHS=16383/16/63, TrkSize=0, SectSize=0, ECCbytes=4
 BuffType=unknown, BuffSize=8192kB, MaxMultSect=16, MultSect=?16?
 CurCHS=16383/16/63, CurSects=16514064, LBA=yes, LBAsects=195371568
 IORDY=on/off, tPIO={min:240,w/IORDY:120}, tDMA={min:120,rec:120}
 PIO modes:  pio0 pio1 pio2 pio3 pio4 
 DMA modes:  mdma0 mdma1 mdma2 
 UDMA modes: udma0 udma1 udma2 udma3 udma4 udma5 
 AdvancedPM=yes: unknown setting WriteCache=enabled
 Drive conforms to: Unspecified:  ATA/ATAPI-1,2,3,4,5,6,7

Sorry if this is the wrong place, I'm new to Bugzilla


Comment 8 James Eniti 2007-11-28 12:53:34 EST
Created attachment 271551 [details]
log file for alienware laptop Hang

The hang that I noted the time for was Nov 26 09:24:29
Comment 9 James Eniti 2007-11-28 13:00:46 EST
(In reply to comment #6)
> Yes, I hear and obey. However, this is just a sudden disconnect. I highly
> doubt that Linux (including both HAL and kernel) did anything to precipitate
> it. It's just a duff enclosure, most likely the power.

On my laptop the backup was NAS via NFS (no power problem, UPS backed)
NO LOG FILE ENTRIES from this repeatable HANG
occurs during large writes to disk from high speed source ( I would look for
table overflow possibles)
Comment 10 Christopher Brown 2008-02-13 17:27:21 EST
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the Fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel?

If the problem no longer exists then please close this bug or I'll do so in a
few weeks if there is no additional information lodged.
Comment 11 David Florence 2008-02-13 18:40:24 EST
Christopher,
Apologize for not following up sooner. The problem has been solved, in my case.
It turned out to be a system power supply problem.

Dave
Comment 12 James Eniti 2008-02-14 04:49:59 EST
fixed in kernals :
Fedora (2.6.23.15-137.fc8)
Fedora (2.6.23.14-115.fc8)

I was on vacation and can't tell exactly when the fix came in but it was after
Dec 27 2007

Thanks
James

Note You need to log in before you can comment on or make changes to this bug.