Bug 387621 - Crash when looking for a new phone [NEEDINFO]
Crash when looking for a new phone
Product: Fedora
Classification: Fedora
Component: wammu (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Xavier Lamien
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-11-16 15:46 EST by Mauricio Pretto
Modified: 2009-01-09 00:14 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-01-09 00:14:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
lxtnow: needinfo? (mauricio)

Attachments (Terms of Use)
bug reprot (484.26 KB, text/plain)
2007-11-16 15:46 EST, Mauricio Pretto
no flags Details
Wammu Bug Report (433.65 KB, text/plain)
2007-11-21 17:49 EST, Phil
no flags Details
wammu stack trace (475.23 KB, text/plain)
2008-03-02 05:54 EST, Adrin Jalali
no flags Details
wammu log (1.35 KB, text/plain)
2008-03-02 06:59 EST, Adrin Jalali
no flags Details
wammu stack trace (464.98 KB, text/plain)
2008-03-02 07:00 EST, Adrin Jalali
no flags Details
wammu crash log (79.94 KB, image/png)
2008-03-02 07:17 EST, Adrin Jalali
no flags Details

  None (edit)
Description Mauricio Pretto 2007-11-16 15:46:36 EST
Description of problem:
I just installed wammu and tried to use with my sony ericsson mobile and python
its crashing while looking for the phone.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Open Wammu
2. go to settings
3. Connection / ADD+
4. Choose "Automatically Search for a phone"
5. Search all connections
Actual results:
The software crashes 

Expected results:

Additional info:
Comment 1 Mauricio Pretto 2007-11-16 15:46:36 EST
Created attachment 261771 [details]
bug reprot
Comment 2 Phil 2007-11-21 17:49:40 EST
Created attachment 266361 [details]
Wammu Bug Report
Comment 3 Phil 2007-11-21 17:51:43 EST
I have the same problem connecting a Nokia 6300.
Comment 4 Xavier Lamien 2007-11-29 17:28:45 EST
SOrry i was a bit busy at work.

Could you tell me which version currently crashed on your fedora release ?

I've actually only my e65 which correctly monted on wammu.
I'll try to find unlike one to make a try.
Comment 5 Adrin Jalali 2008-03-02 05:52:38 EST
having sony ericsson k750 the same problem. trace attached.

Comment 6 Adrin Jalali 2008-03-02 05:54:06 EST
Created attachment 296504 [details]
wammu stack trace
Comment 7 Xavier Lamien 2008-03-02 06:22:37 EST
Updated releases of Wammu and Gammu have been pushed to testing repository.
Could make some try with this one ?

If still crash, also attach your .log stored in /tmp/WammuXXXXX.log
Comment 8 Xavier Lamien 2008-03-02 06:23:21 EST
s/could/&\ you/
Comment 9 Adrin Jalali 2008-03-02 06:59:18 EST
Created attachment 296506 [details]
wammu log

again crashes.
Comment 10 Adrin Jalali 2008-03-02 07:00:47 EST
Created attachment 296507 [details]
wammu stack trace

the new stack trace is attached.
Comment 11 Adrin Jalali 2008-03-02 07:17:13 EST
Created attachment 296508 [details]
wammu crash log

I just tried to connect to /dev/ttyACM0 with root (because it says that my user
does not have required permission) and a message appears which can not be
copied. It says it is saved in /tmp automatically, but that file is empty, so I
attach a picture of that.
Comment 12 Xavier Lamien 2008-03-05 17:21:50 EST
An fresh upstream release has been built.
Fixed a couple of reported crashes issues.

Available here : http://koji.fedoraproject.org/koji/taskinfo?taskID=495206

Could you make some tries with this new one ?
Comment 13 Amanda Christensen 2008-03-29 21:41:03 EDT
I'm having this problem as well.  Using version 0.19-3.fc8.
Comment 14 Xavier Lamien 2008-03-31 08:06:52 EDT
Could you please take in account the comment #12, thanks.

it's available in updates-testing repository.
just perform :
# yum --enable updates-testing update wammu
Comment 15 Bug Zapper 2008-11-26 03:30:54 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 16 Bug Zapper 2009-01-09 00:14:45 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.