Bug 387701 - oocalc 2.3 very slow for simple operations
oocalc 2.3 very slow for simple operations
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
8
i686 Linux
low Severity low
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-16 16:51 EST by Airbete
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-19 06:52:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test file (21.86 KB, application/vnd.oasis.opendocument.spreadsheet)
2007-11-16 16:51 EST, Airbete
no flags Details
Test file 2 (15.13 KB, application/vnd.oasis.opendocument.spreadsheet)
2007-11-17 10:28 EST, Airbete
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 83712 None None None Never

  None (edit)
Description Airbete 2007-11-16 16:51:23 EST
Description of problem:

oocalc 2.3 on Fedora 8 is very slow compared to oocalc 2.0 on Fedora 6 even for
simple operation such as adding a column or turning off AutoCalculation

Version-Release number of selected component (if applicable): 2.3

How reproducible: Always

To reproduce the bug, please see the attached file. There is a small macro in it
(a math function) but it can be turned off as it doesn't affect the following
results.

(*) right-click on column "N" (or any other) and choose "insert columns"

Then 
1) in oocalc 2.3 on Fedora 8 it takes 13 seconds to do (*)
2) this time is reduced to less than 1 second if AutoCalculate is turned off.
3) in oocalc 2.0 on Fedora 6 it takes less than 1 second to do (*) whether or
not AutoCalculate is on.

(**) turn off AutoCalculate (via F9 or the menu)

4) in oocalc 2.3 on Fedora 8 it takes 7 seconds to accomplish (**)
5) in oocalc 2.0 on Fedora 6 it takes less than 1 second to do (**)

Packages installed:

On the Fedora 8 box:
openoffice.org-calc-2.3.0-6.6.fc8.rpm

On the Fedora 6 box:
openoffice.org-calc-2.0.4-5.5.24.rpm

Remarks.

a) The larger the worksheet, the longer the times in 1) and 4). For some of
my worksheets, it takes an hour to add a single column in oocalc 2.3 while it
takes a second or two in oocalc 2.0. It looks like oocalc 2.3 is recalculating
everything thousands of times when it is not necessary.

b) As everything works fine in oocalc 2.0 on Fedora 6, I don't for sure that the
problem is in oocalc 2.3. It might be the result of a bug in a library that
comes with Fedora 8. This is why I have filled a bug report both here and at
openoffice.org.
Comment 1 Airbete 2007-11-16 16:51:23 EST
Created attachment 261891 [details]
Test file
Comment 2 Caolan McNamara 2007-11-16 18:06:38 EST
What's the upstream OOo bug id ? It is possible as a first thought that this is
due to increasing the number of available rows in calc.
Comment 3 Airbete 2007-11-17 10:27:54 EST
> upstream OOo bug id

Sorry, I don't know what this is. I am unfamiliar with the OO bug system.

> It is possible as a first thought that this is
> due to increasing the number of available rows in calc.

The sheet sizes look the same in 2.0 and 2.3: 65536x256 for each.

I have attached another file (Test file 2) which shows an even stranger behavior.

1) right-click on column L and select delete columns: 6 seconds (very long).
2) undo (ctrl-z): < 1s (that's ok)
3) right-click on column L and select insert column: < 1s (that's ok)
4) undo (ctrl-z): 8 seconds (much too long)
5) select columns L and U (with ctrl), right-click on column U and select delete
columns: < 1s !! (that's ok)



Comment 4 Airbete 2007-11-17 10:28:27 EST
Created attachment 262281 [details]
Test file 2
Comment 5 Caolan McNamara 2007-11-19 06:52:53 EST
I see this slowness, some tests with the "upstream" rpms show they have the same
problem as well. So not specific to our build, so moving this to the upstream
tracker, i.e. http://www.openoffice.org/issues/show_bug.cgi?id=83712

Note You need to log in before you can comment on or make changes to this bug.