Bug 387791 - Fails to install gdm dependency nss (for libssl3.so)
Fails to install gdm dependency nss (for libssl3.so)
Status: CLOSED DUPLICATE of bug 388951
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
i686 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-16 17:46 EST by Moritz Barsnick
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-17 15:20:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moritz Barsnick 2007-11-16 17:46:14 EST
Description of problem:
On a fresh install, it seems that anaconda failed to install the nss package 
for gdm. This would provide libssl3.so, without which gdm cannot run.

Version-Release number of selected component (if applicable):
Fedora 8 initial version

How reproducible:
Tried only once.

Actual results:
Right after every boot (also after firstboot), you get:
Fedora release 8 [...]
[...]
INIT: Id "x" respawing too fast, disabled for 5 minutes

Expected results:
gdm starts up.

Additional info:
I checked the 'x' entry in /etc/inittab, ran the script there with sh -x, and 
finally figured out that /usr/sbin/gdm couldn't execute because it was missing 
libssl3.so. "ldd" confirms this fact.

Executing "startx" as a normal user actually works sort of fine.
Comment 1 Moritz Barsnick 2007-11-16 18:19:09 EST
Oh, they joy of optical media.

A second run failed at the media check. Let me put this on hold until I can 
confirm it is not due to the flaky DVD-R. (D**n, it was Verbatim! They're 
supposed to work!)
Comment 2 Moritz Barsnick 2007-11-17 15:20:44 EST
Okay, with a "clean" install medium, I cannot reproduce this. I assume the bad 
medium was the reason, but I forgot to check the install logs (and they're 
nuked now ;->).

Sorry for the noise. -> Closed.
Comment 3 Michal Jaegermann 2007-11-17 21:57:05 EST
I am not so sure if you were not too hasty closing that.
I am seeing something similar with different packages.
Initially filed against cups as bug 388951 but closer look
seems to indicate that anaconda is at fault.
Comment 4 Moritz Barsnick 2007-11-18 08:28:19 EST
Re comment #3:
Michal,
good point. But unfortunately, I had looked at all sorts of stuff, but forgot 
that there was a /root/install.log. Your log file looks as if anaconda indeed 
actually missed that dependency during install.

I also didn't get any error messages during install. Back in Fedora Code 4/5/6 
or so, I got "cannot read soandso.foo.rpm" if there were problems with the 
install medium. So perhaps there are indeed random problems within anaconda. 
Just I can't reproduce. I'll try to do this behavior justice and change my bug 
closure to a dupe of yours, if you don't mind. I won't be helpful in debug 
anymore though, sorry.

*** This bug has been marked as a duplicate of 388951 ***
Comment 5 Michal Jaegermann 2007-11-18 12:54:06 EST
> Just I can't reproduce.

I may try later on to go through an installation exercise again
and see what will happen.  Too many instances which look strangely
similar.

Note You need to log in before you can comment on or make changes to this bug.