Bug 38789 - qt1x demands libstdc++-libc6.1-1.so.2
qt1x demands libstdc++-libc6.1-1.so.2
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: qt1x (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-02 12:32 EDT by mike
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-02 12:32:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mike 2001-05-02 12:32:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.2-2smp i686; en-US; 0.8.1)
Gecko/20010421


I'm recompiling some of my software under RH7.1 (mostly), one module of
which needs qt1x, which I have installed (qt1x-1.45-12).  Unfortunately,
this version of qt1x seems to require an older (libstdc++-libc6.1-1)
version of libstdc++ than I have (libstdc++-libc6.2.2.so.3).  This is also
a problem because the older libstdc++ causes a bad problem with exception
handling anytime it's linked in.

The message I get from g++ is:
/usr/bin/ld: warning: libstdc++-libc6.1-1.so.2, needed by
/usr/lib/qt-1.45/lib/libqt.so, not found (try using --rpath)

Reproducible: Always
Steps to Reproduce:
1. link c++ program with -lqt
2.
3.
Comment 1 Ngo Than 2001-05-02 14:26:05 EDT
the only reason why qt1x requires libstdc++-libc6.1-1.so.2, is backward
compatibility with the old programs in RHL 6.x and 7.0.

If you want to use the new libstdc++, please uses qt-2.3.0.

Note You need to log in before you can comment on or make changes to this bug.