From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.2-2smp i686; en-US; 0.8.1)
I'm recompiling some of my software under RH7.1 (mostly), one module of
which needs qt1x, which I have installed (qt1x-1.45-12). Unfortunately,
this version of qt1x seems to require an older (libstdc++-libc6.1-1)
version of libstdc++ than I have (libstdc++-libc6.2.2.so.3). This is also
a problem because the older libstdc++ causes a bad problem with exception
handling anytime it's linked in.
The message I get from g++ is:
/usr/bin/ld: warning: libstdc++-libc6.1-1.so.2, needed by
/usr/lib/qt-1.45/lib/libqt.so, not found (try using --rpath)
Steps to Reproduce:
1. link c++ program with -lqt
the only reason why qt1x requires libstdc++-libc6.1-1.so.2, is backward
compatibility with the old programs in RHL 6.x and 7.0.
If you want to use the new libstdc++, please uses qt-2.3.0.