Bug 388141 - Yumex crashes: making changes in Edit > Preferences > GUI fails, and crashes yumex
Yumex crashes: making changes in Edit > Preferences > GUI fails, and crashes ...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
8
All Linux
low Severity urgent
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-17 01:14 EST by Mariusz Wodzicki
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-18 02:12:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mariusz Wodzicki 2007-11-17 01:14:08 EST
Description of problem:

Suppose you want to change the font size in a running yumex (I open yumex from
Applications > System Tools menu):

1) In yumex window you select Edit > Preferences > GUI
2) You change the font size, then click `OK' (the font selection window disappears).
3) Then you click again `OK' on the Preferences window -- NO RESPONSE.

If you click `Cancel', the Preferences window disappears, but the yumex main
window blanks.

When you click to close it, you get a message that yumex is non-responsive, and
you are asked whether to "Wait" , or to "Force Quit" it. You choose "Force
Quit". The yumex window disappears BUT yumex is still running:

In the above sequence, you don't have to make any changes in the Preferences >
GUI tab. It is sufficient to open it, and then to click `Cancel' -- the same result.

$ ps -Af|grep yumex
wodzicki  7087     1  0 21:34 ?        00:00:00 /usr/bin/yumex
root      7088  7087  0 21:34 ?        00:00:00 /usr/sbin/userhelper -w yumex
root      7092  7088  0 21:34 ?        00:00:00 /bin/bash /usr/share/yumex/yumex
root      7093  7092  2 21:34 ?        00:00:16 /usr/bin/python
/usr/share/yumex/yumex.pyc

I need `kill -9' to kill it.


Version-Release number of selected component (if applicable):

yumex-2.0.2-1.fc8
yum-3.2.7-1.fc8

related packages:

yum-metadata-parser-1.1.2-1.fc8
yum-utils-1.1.8-1.fc8
yum-fedorakmod-1.1.8-1.fc8
yum-kernel-module-1.1.8-1.fc8
yumex-2.0.2-1.fc8
yum-fastestmirror-1.1.8-1.fc8
How reproducible:


Steps to Reproduce: described above. The behavior described happens every time.
  
Actual results:
Due to this bug yumex becomes totally inoperational, and "Force Quit" removes
only the GUI window while several related processes are still running which
renders impossible restarting yumex, or executing yum from the command line,
before killing first all of these processes manually.

Expected results:
Using Edit > Preferences should not crash the application.

Additional info:
Comment 1 Mariusz Wodzicki 2007-11-17 01:42:57 EST
I performed an additional test. I did log in as a root into a GNOME desktop
environment, opened yumex from the menu and repeated the steps described in my
report. Nearly the same results.

The only difference is that when you "Force Quit" the yumex GUI window, this
terminates all the related processes -- unlike when you start yumex as a
non-root [in that case, of course, you still need to type the root password in a
pop-up form in order to continue].  
Comment 2 Tim Lauridsen 2007-11-18 02:12:08 EST
Thanks, i can reproduce this error, it is already fixed upstream, i will make a
new release soon

Note You need to log in before you can comment on or make changes to this bug.