Bug 388301 - anaconda throws exception when trying to create more than 4 primary partitions
anaconda throws exception when trying to create more than 4 primary partitions
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
i386 Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-11-17 07:41 EST by Roland Schnabel
Modified: 2008-08-06 16:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-08-06 16:54:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Roland Schnabel 2007-11-17 07:41:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20071008 Firefox/

Description of problem:
I tried to install fc8 on my notebook. As there are already some partitions, and also free disk space, I tried to create a new partition in that free space. I selected the free diskspace and hit the "Edit"-Button. I specified "/" as mount point, "ext3" as file system type, and reduced the number of cylinders, so that I am able to create another new swap partition afterwards. After selecting the "Ok"-Button, anaconda threw an exception, as there are already 4 primary partitions on that disk.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Run FC8 installation on an a partitioned system with some free disk space that is not already partitioned. The target disk has already 4 primary partitions.

2. Within anaconda edit the empty disk space.

3. Reduce the number of cylinders for the new partition and fill out the rest of the fields.

4. Hit the "Ok"-Button.

Actual Results:
Anaconda threw an exception, installation aborted and the system was shut down.

Expected Results:
Anaconda shows an appropriate error message (e.g. "not able to create more than 4 primary partitions on that disk"), and give the user one or more options to continue installation.

Additional info:
File "/usr/lib/anaconda/autopart.py", line 955, in processPartitioning
raise PartitioningError, _("Could not allocate cylinder-based partitions as primary partitions.\n\n%s")%msg

File "/usr/lib/anaconda/autopart.py", line 1014, in doPartitioning
processPartitioning(diskset, requests, newParts)

File "/usr/lib/anaconda/iw/partition_gui.py", line 1000, in refresh
autopart.doPartitioning(self.diskset, self.partitions)
Comment 1 Jeremy Katz 2007-11-19 10:47:18 EST
Can you attach the complete traceback?
Comment 2 Roland Schnabel 2007-11-19 11:57:13 EST
Sorry, as this happens before hardware support is installed, and there is no
floppy drive attached to my notebook, I am stuck with pen and paper. I am not
sure how I can transfer the trace file from the installation machine without any
network / mounted partitions / etc.

Also because I have installed Fedora 8 in the meantime, there is no free space
left on my notebook. So I can not reproduce the problem on this machine. I am
trying to create the same environment on a different PC. 
Comment 3 David Cantrell 2008-04-23 18:47:39 EDT
With the Fedora 9 Preview release, I am unable to reproduce the actual results you describe in the 
opening comment.

Some questions:
1) Is your disk using the DOS parititon table (MBR)?
2) When you were checking the 'Force to be a primary partition' in the Add Partition dialog?

The DOS partition table only supports 4 primary partitions:

If you were trying to add a 5th, anaconda will stop you.  With the Fedora 9 Preview release, we are 
throwing an exception and catching it.  We warn you and then put you back at the Add Partition dialog 
box so you can make changes (hopefully unchecking 'Force to be a primary partition').  I am unable to 
get it to crash given the situation you described.

Can you try the Fedora 9 Preview release and see if the problem still occurs?

Note You need to log in before you can comment on or make changes to this bug.