Bug 388371 - setresuid failed with EAGAIN
setresuid failed with EAGAIN
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Simo Sorce
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-17 10:27 EST by Paul Howarth
Modified: 2008-03-29 11:26 EDT (History)
1 user (show)

See Also:
Fixed In Version: 3.0.28a
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-29 11:26:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Howarth 2007-11-17 10:27:43 EST
Intermittent crashes with tracebacks like this:
Nov 17 15:04:19 metropolis smbd[17029]: [2007/11/17 15:04:19, 0]
lib/util_sec.c:set_effective_uid(205) 
Nov 17 15:04:19 metropolis smbd[17029]:   setresuid failed with EAGAIN. uid(514)
might be over its NPROC limit 
Nov 17 15:04:20 metropolis smbd[17029]: [2007/11/17 15:04:19, 0]
lib/util_sec.c:assert_uid(101) 
Nov 17 15:04:20 metropolis smbd[17029]:   Failed to set uid privileges to
(-1,514) now set to (0,0) 
Nov 17 15:04:20 metropolis smbd[17029]: [2007/11/17 15:04:19, 0]
lib/util.c:smb_panic(1654) 
Nov 17 15:04:20 metropolis smbd[17029]:   PANIC (pid 17029): failed to set uid 
Nov 17 15:04:20 metropolis smbd[17029]:    
Nov 17 15:04:20 metropolis smbd[17029]: [2007/11/17 15:04:20, 0]
lib/util.c:log_stack_trace(1758) 
Nov 17 15:04:20 metropolis smbd[17029]:   BACKTRACE: 11 stack frames: 
Nov 17 15:04:20 metropolis smbd[17029]:    #0 smbd(log_stack_trace+0x1c)
[0x2aaaaacceb2c] 
Nov 17 15:04:20 metropolis smbd[17029]:    #1 smbd(smb_panic+0x43) [0x2aaaaaccec13] 
Nov 17 15:04:20 metropolis smbd[17029]:    #2 smbd [0x2aaaaacd3e61] 
Nov 17 15:04:20 metropolis smbd[17029]:    #3 smbd [0x2aaaaab7236e] 
Nov 17 15:04:20 metropolis smbd[17029]:    #4 smbd(set_sec_ctx+0x108)
[0x2aaaaab726e8] 
Nov 17 15:04:20 metropolis smbd[17029]:    #5 smbd(change_to_user+0x219)
[0x2aaaaab68159] 
Nov 17 15:04:20 metropolis smbd[17029]:    #6 smbd [0x2aaaaab8093b] 
Nov 17 15:04:20 metropolis smbd[17029]:    #7 smbd(smbd_process+0x7b1)
[0x2aaaaab81bf1] 
Nov 17 15:04:20 metropolis smbd[17029]:    #8 smbd(main+0xa20) [0x2aaaaad83520] 
Nov 17 15:04:20 metropolis smbd[17029]:    #9
/lib64/libc.so.6(__libc_start_main+0xf4) [0x2aaaad960ab4] 
Nov 17 15:04:20 metropolis smbd[17029]:    #10 smbd [0x2aaaaab13089] 
Nov 17 15:04:20 metropolis smbd[17029]: [2007/11/17 15:04:20, 0]
lib/fault.c:dump_core(181) 
Nov 17 15:04:20 metropolis smbd[17029]:   dumping core in /var/log/samba/cores/smbd 
Nov 17 15:04:20 metropolis smbd[17029]: 

Share config:
[Private Data]
  comment = Paul and Bingning's Private Data
  path = /srv/privdata
  valid users = paul bingning
  public = no
  writeable = yes
  printable = no
  force user = privdata
  force group = privdata

Version-Release number of selected component (if applicable):
samba-3.0.26a-6.fc7; I'm just upgrading to 3.0.27-0.fc7 and will add a note if I
get another crash.

How reproducible:
I get this sporadically (not every session, and it takes a while to happen) when
I use MS Money on an XP VMware guest accessing an F7 samba server on the host
machine.

Similar report, probably different trigger here:
http://www.redhat.com/archives/rhl-list/2007-August/msg03484.html
http://lists.samba.org/archive/samba/2007-August/134556.html
Comment 1 Paul Howarth 2008-03-04 08:55:24 EST
This is happening more frequently now on F8, and not just when using VMware -
I've also seen it using the same application (MS Money) on a Windows XP client.

A consequence of the crash is typically that the Money database is corrupted,
resulting in the loss of work done in that session (the backup that MS Money
created at the end of the previous session is still generally usable to recover
from).

I've also noticed that if I move the money file from the share as configured in
the original report to my home directory (a standard "homes" share), I have yet
to see the crash there.

Latest traceback:

Mar  4 08:52:18 metropolis smbd[1780]: [2008/03/04 08:52:18, 0]
lib/util_sec.c:set_effective_uid(205)
Mar  4 08:52:18 metropolis smbd[1780]:   setresuid failed with EAGAIN. uid(514)
might be over its NPROC limit
Mar  4 08:52:18 metropolis smbd[1780]: [2008/03/04 08:52:18, 0]
lib/util_sec.c:assert_uid(101)
Mar  4 08:52:18 metropolis smbd[1780]:   Failed to set uid privileges to
(-1,514) now set to (0,0)
Mar  4 08:52:18 metropolis smbd[1780]: [2008/03/04 08:52:18, 0]
lib/util.c:smb_panic(1655)
Mar  4 08:52:18 metropolis smbd[1780]:   PANIC (pid 1780): failed to set uid
Mar  4 08:52:18 metropolis smbd[1780]:
Mar  4 08:52:18 metropolis smbd[1780]: [2008/03/04 08:52:18, 0]
lib/util.c:log_stack_trace(1759)
Mar  4 08:52:18 metropolis smbd[1780]:   BACKTRACE: 13 stack frames:
Mar  4 08:52:18 metropolis smbd[1780]:    #0 smbd(log_stack_trace+0x1c)
[0x2aaaaacce77c]
Mar  4 08:52:18 metropolis smbd[1780]:    #1 smbd(smb_panic+0x43) [0x2aaaaacce863]
Mar  4 08:52:18 metropolis smbd[1780]:    #2 smbd [0x2aaaaacd3b41]
Mar  4 08:52:18 metropolis smbd[1780]:    #3 smbd [0x2aaaaab7255e]
Mar  4 08:52:18 metropolis smbd[1780]:    #4 smbd(pop_sec_ctx+0x96) [0x2aaaaab726d6]
Mar  4 08:52:18 metropolis smbd[1780]:    #5 smbd(unbecome_root+0x9)
[0x2aaaaab67ee9]
Mar  4 08:52:18 metropolis smbd[1780]:    #6 smbd(gid_to_sid+0x168) [0x2aaaaac8dfb8]
Mar  4 08:52:18 metropolis smbd[1780]:    #7 smbd(change_to_user+0x5cb)
[0x2aaaaab686bb]
Mar  4 08:52:18 metropolis smbd[1780]:    #8 smbd [0x2aaaaab8044b]
Mar  4 08:52:18 metropolis smbd[1780]:    #9 smbd(smbd_process+0x7b1)
[0x2aaaaab81701]
Mar  4 08:52:18 metropolis smbd[1780]:    #10 smbd(main+0xa20) [0x2aaaaad83250]
Mar  4 08:52:18 metropolis smbd[1780]:    #11
/lib64/libc.so.6(__libc_start_main+0xf4) [0x2aaaad967074]
Mar  4 08:52:18 metropolis smbd[1780]:    #12 smbd [0x2aaaaab130d9]
Mar  4 08:52:18 metropolis smbd[1780]: [2008/03/04 08:52:18, 0]
lib/fault.c:dump_core(181)
Mar  4 08:52:18 metropolis smbd[1780]:   dumping core in /var/log/samba/cores/smbd
Mar  4 08:52:18 metropolis smbd[1780]:

# rpm -qa samba\*
samba-common-3.0.28-0.fc8
samba-client-3.0.28-0.fc8
samba-3.0.28-0.fc8
Comment 2 Simo Sorce 2008-03-25 15:08:10 EDT
Can you check if this still happens with 3.0.28a packages?
Comment 3 Paul Howarth 2008-03-29 05:41:41 EDT
I've run four MS Money sessions this week since updating to 3.0.28a and haven't
had a crash in any of them. Given the intermittent nature of the problem, I'm
not completely sure it's fixed; I think I'd have to go a month or so without a
crash for that. It's looking a lot better though, as the crashes had been quite
frequent before the upgrade.
Comment 4 Simo Sorce 2008-03-29 11:26:12 EDT
Ok I will close this as fixed, reopen if it happens again

Note You need to log in before you can comment on or make changes to this bug.