Bug 38871 - kernel 2.4.2-2 does not lock zip drive when mounted
Summary: kernel 2.4.2-2 does not lock zip drive when mounted
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
: 37072 41804 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-03 00:53 UTC by Carlos Rodrigues
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-25 20:54:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Carlos Rodrigues 2001-05-03 00:53:59 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i686)


After mounting a zip drive the disk doesn't get locked in the drive, I can
eject it without unmounting.

Reproducible: Always
Steps to Reproduce:
1. insert zip disk in drive
2. mount it
3. press eject
	

Actual Results:  The disk pops out.

Expected Results:  The disk should of stayed inside until unmount.

Comment 1 Arjan van de Ven 2001-05-03 07:58:45 UTC
Can you try disabling "magicdev" and/or "autorun" in the Control Center?
This program tends to cause this kind of behavior.



Comment 2 Carlos Rodrigues 2001-05-03 21:59:10 UTC
Both magicdev and autorun are disabled.

I forgot to mention that the drive is a zip 100 plus connected to a ISA Iomega
Zoom SCSI card.

Comment 3 Tim Lundstrvm 2001-05-04 07:20:15 UTC
The same goes for the paralell port Zip-drive with ppa-module

Comment 4 Alan Cox 2001-05-28 17:57:57 UTC
*** Bug 41804 has been marked as a duplicate of this bug. ***

Comment 5 Alan Cox 2001-05-28 17:59:28 UTC
*** Bug 37072 has been marked as a duplicate of this bug. ***

Comment 6 Carlos Rodrigues 2001-06-25 20:54:43 UTC
For me, kernel 2.4.3-12 from updates.redhat.com fixes this problem.


Note You need to log in before you can comment on or make changes to this bug.