Bug 388761 - dangling symlinks
dangling symlinks
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Inventor (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ralf Corsepius
Fedora Extras Quality Assurance
: Reopened
Depends On: 426560
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-17 15:46 EST by Florian La Roche
Modified: 2014-01-21 18:00 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.1.5-30.fc8.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-30 05:31:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florian La Roche 2007-11-17 15:46:03 EST
Description of problem:
Inventor ships a couple of dangling symlinks. A quick checks looks like
the dejavu fonts have just moved into a new directory:

Inventor has dangling symlink from /usr/share/Inventor/fonts/Courier to
/usr/share/fonts/dejavu-fonts/DejaVuSerifCondensed.ttf
Inventor has dangling symlink from /usr/share/Inventor/fonts/Courier-Bold to
/usr/share/fonts/dejavu-fonts/DejaVuSerifCondensed-Bold.ttf
Inventor has dangling symlink from /usr/share/Inventor/fonts/Courier-BoldOblique
to /usr/share/fonts/dejavu-fonts/DejaVuSerifCondensed.ttf
Inventor has dangling symlink from /usr/share/Inventor/fonts/Courier-Oblique to
/usr/share/fonts/dejavu-fonts/DejaVuSerifCondensed-Oblique.tt
f
Inventor has dangling symlink from /usr/share/Inventor/fonts/Helvetica to
/usr/share/fonts/dejavu-fonts/DejaVuSans.ttf
Inventor has dangling symlink from /usr/share/Inventor/fonts/Helvetica-Bold to
/usr/share/fonts/dejavu-fonts/DejaVuSans-Bold.ttf
Inventor has dangling symlink from
/usr/share/Inventor/fonts/Helvetica-BoldOblique to
/usr/share/fonts/dejavu-fonts/DejaVuSans.ttf
Inventor has dangling symlink from /usr/share/Inventor/fonts/Helvetica-Oblique
to /usr/share/fonts/dejavu-fonts/DejaVuSans-Oblique.ttf
Inventor has dangling symlink from /usr/share/Inventor/fonts/Times-Roman to
/usr/share/fonts/dejavu-fonts/DejaVuSerif.ttf
Inventor has dangling symlink from /usr/share/Inventor/fonts/Utopia-Bold to
/usr/share/fonts/dejavu-fonts/DejaVuSerif-Bold.ttf
Inventor has dangling symlink from /usr/share/Inventor/fonts/Utopia-BoldItalic
to /usr/share/fonts/dejavu-fonts/DejaVuSerif-BoldOblique.ttf
Inventor has dangling symlink from /usr/share/Inventor/fonts/Utopia-Italic to
/usr/share/fonts/dejavu-fonts/DejaVuSerif-Oblique.ttf
Inventor has dangling symlink from /usr/share/Inventor/fonts/Utopia-Regular to
/usr/share/fonts/dejavu-fonts/DejaVuSerif.ttf



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Ralf Corsepius 2007-11-18 02:50:33 EST
Thanks for the report, I don't know what has happened to dejavu-fonts (I did
check when you reported this to the devel-list and didn't notice anything
unusual). I am looking into this.

Seems as if dejavu-fonts have been moved around between packages (some now seem
to be *-experimental), dirs been altered etc (some fedora versions have them in
.../dejavu, some in .../dejavu-fonts).

I'll probably switch away from using dejavu-fonts in favor of liberation-fonts
and hard-code file deps into Inventor's spec.
Comment 2 Fedora Update System 2007-11-20 12:52:00 EST
Inventor-2.1.5-30.fc8.1 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 3 Fedora Update System 2007-11-20 13:03:45 EST
Inventor-2.1.5-29.fc7.1 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 4 Ralf Corsepius 2007-12-14 08:14:17 EST
Something in yum/mock or createrepo has caused my fix to break which had worked
some time ago (otherwise this package would not have been released).


ATM, rebuilding Inventor-2.1.5-30.fc8.1 in mock fails with
...
ERROR: Bad build req: No Package Found for
/usr/share/fonts/liberation/LiberationSerif-Italic.ttf. Exiting.
...

Rebuilding the identical spec for fc9 succeeds.

Wild guess: A version of createrepo has been used on FC8's repo which breaks the
file deps my spec depends upon.

BTW: this issue is easily reproducable on FC8:
yum install /usr/share/fonts/liberation/LiberationSerif-Italic.ttf
Comment 5 Jesse Keating 2007-12-14 09:28:38 EST
Actually it isn't broken.  There might be something broken in yum though.  If
you run yum as root it can resolve that dep, since it'll pull down the filelists
metadata:

$ sudo yum resolvedep /usr/share/fonts/liberation/LiberationSerif-Italic.ttf
Loading "dellsysidplugin" plugin
Loading "refresh-updatesd" plugin
updates-testing           100% |=========================| 2.3 kB    00:00     
primary.sqlite.bz2        100% |=========================| 391 kB    00:00     
livna                     100% |=========================| 2.1 kB    00:00     
dell-software             100% |=========================| 1.9 kB    00:00     
fedora                    100% |=========================| 2.1 kB    00:00     
adobe-linux-i386          100% |=========================|  951 B    00:00     
primary.xml.gz            100% |=========================| 1.3 kB    00:00     
fwupdate                  100% |=========================| 1.9 kB    00:00     
updates                   100% |=========================| 2.3 kB    00:00     
Importing additional filelist information
filelists.sqlite.bz2      100% |=========================| 773 kB    00:01     
filelists.xml.gz          100% |=========================|  483 B    00:00     
0:liberation-fonts-0.2-3.fc8.noarch
Comment 6 Seth Vidal 2007-12-14 09:34:15 EST
I thought mebrown said the other day that there was a problem with the
resolvedep call in mock b/c it ran unprivileged so yum could not pull down new
metadata to find a resolution on the above.

Comment 7 Jesse Keating 2007-12-14 09:49:20 EST
Yes, that was it.
Comment 8 Ralf Corsepius 2007-12-14 09:51:44 EST
In reply to comment #5)
> Actually it isn't broken.

Weird. Right now 
yum install /usr/share/fonts/liberation/LiberationSerif-Italic.ttf
works (It didn't when I tried before reopening this bug.)

Still rebuilding in mock fails:

[packman@beck F-8]$ make mockbuild
rpmbuild --define "_sourcedir /users/packman/src/fedora/pkgs/rpms/Inventor/F-8"
--define "_specdir /users/packman/src/fedora/pkgs/rpms/Inventor/F-8" --define
"_builddir /users/packman/src/fedora/pkgs/rpms/Inventor/F-8" --define
"_srcrpmdir /users/packman/src/fedora/pkgs/rpms/Inventor/F-8" --define "_rpmdir
/users/packman/src/fedora/pkgs/rpms/Inventor/F-8" --define "dist .fc8" --define
"fedora 8" --define "dist .fc8" --define "fedora 8" --nodeps -bs Inventor.spec
Wrote:
/users/packman/src/fedora/pkgs/rpms/Inventor/F-8/Inventor-2.1.5-30.fc8.1.src.rpm
mock  -r fedora-8-x86_64
--resultdir=/users/packman/src/fedora/pkgs/rpms/Inventor/F-8/Inventor-2_1_5-30_fc8_1
rebuild
/users/packman/src/fedora/pkgs/rpms/Inventor/F-8/Inventor-2.1.5-30.fc8.1.src.rpm
INFO: mock.py version 0.8.17 starting...
State Changed: init plugins
State Changed: start
INFO:
Start(/users/packman/src/fedora/pkgs/rpms/Inventor/F-8/Inventor-2.1.5-30.fc8.1.src.rpm)
 Config(fedora-8-x86_64)
State Changed: lock buildroot
State Changed: clean
State Changed: init
State Changed: lock buildroot
INFO: enabled yum cache
State Changed: cleaning yum metadata
INFO: enabled root cache
State Changed: unpacking cache
State Changed: running yum
State Changed: setup
ERROR:
Exception(/users/packman/src/fedora/pkgs/rpms/Inventor/F-8/Inventor-2.1.5-30.fc8.1.src.rpm)
Config(fedora-8-x86_64) 0 minutes 15 seconds
INFO: Results and/or logs in:
/users/packman/src/fedora/pkgs/rpms/Inventor/F-8/Inventor-2_1_5-30_fc8_1
INFO: Cleaning up build root ('clean_on_failure=True')
State Changed: lock buildroot
State Changed: clean
ERROR: Bad build req: No Package Found for
/usr/share/fonts/liberation/LiberationSerif-Italic.ttf. Exiting.
make: *** [mockbuild] Error 10



(In reply to comment #6)
> I thought mebrown said the other day that there was a problem with the
> resolvedep call in mock b/c it ran unprivileged so yum could not pull down new
> metadata to find a resolution on the above.
Hmm, ... in other words, mock is unusable for the moment?

Any fix in sight?


Comment 9 Ralf Corsepius 2007-12-14 09:56:47 EST
(In reply to comment #6)
Second thought: How comes building from the identical spec succeeds for FC9 but
fails for FC7/FC8 (Same build-host FC8/x86_64)?

Comment 10 Ralf Corsepius 2007-12-14 11:18:36 EST
FWIW: Entirely erasing /var/lib/mock had let my local mock builds succeed.

=> mock and/or its infrastructure has a cache handling problem.
Comment 11 Michael E Brown 2007-12-14 16:49:06 EST
The permissions problem was fixed in mock-0.8.17. This release made it into
updates-stable Dec 14, so it is likely that you upgraded mock which fixed this
rather than any cache handling problem.
Comment 12 Ralf Corsepius 2007-12-14 23:08:19 EST
(In reply to comment #11)
According to /var/log/messages, mock was updated (times are CET)
..
Dec 14 07:55:49 beck yum: Updated: mock - 0.8.17-1.fc8.x86_64
..

I.e. before starting to work on Inventor (ca. 10:00 CET) and before reporting it
(comment #4: 14:14 CET).

So, I'd say either the cache already had been corrupted for other reasons,
independently of the update or the update had broken the cache. I don't know.
Comment 13 Ralf Corsepius 2007-12-21 23:47:27 EST
Bug is still present in mock-0.8.18/yum-3.2.8-2.fc8.

Provided other weirdnesses I am experiencing with this current yum, I think this
current yum is the culprit (read: plain broken).
Comment 14 Ralf Corsepius 2007-12-22 00:39:03 EST
This bug is deterministically reproduceable on FC8:

# yum resolvedep /usr/share/fonts/liberation/LiberationSerif-Italic.ttf
Importing additional filelist information
No Package Found for /usr/share/fonts/liberation/LiberationSerif-Italic.ttf

# rpm -qf /usr/share/fonts/liberation/LiberationSerif-Italic.ttf
liberation-fonts-0.2-3.fc8

Repoquery resolves this dep correctly:
# repoquery --whatprovides /usr/share/fonts/liberation/LiberationSerif-Italic.ttf
liberation-fonts-0:0.2-3.fc8.noarch

=> yum resolvedep as being using internally of mock produces invalid results.

Comment 15 Jesse Keating 2007-12-22 08:25:19 EST
This was temporarily fixed and then regressed.  A fix for this has been checked
into upstream git and a release made on rawhide for it, and an update put into
updates-testing for F8.  Please try with mock-0.8.19-1.fc8
Comment 16 Michael E Brown 2007-12-22 14:43:22 EST
Actually, I think it may never have been fixed. The outer scope always had the
privilege drop, and I dont have any record of anybody emailing me to say that my
first "fix" had actually fixed the issue.

the original code:

   def build():
        drop privs
         ...
        installSrpmDeps()

   def installSrpmDeps():
        drop privs
        call yum resolvedeps
        restore privs
        raise privs
        call yum install foreach dep
        restore to original privs

The original fix only removed the priv drop in installSrpmDeps()
Comment 17 Florian La Roche 2008-01-30 05:16:42 EST
I think we can close this bug-report now. Anyone thinks otherwise?

regards,

Florian La Roche
Comment 18 Ralf Corsepius 2008-01-30 05:31:08 EST
Agreed. If it should persist, then it's likely a mock/yum thing.

Closing again.

Note You need to log in before you can comment on or make changes to this bug.