Bug 38889 - tix can no longer handle xpm images
tix can no longer handle xpm images
Product: Red Hat Linux
Classification: Retired
Component: tcltk (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2001-05-03 04:29 EDT by thomas.bartschies
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-06-28 10:59:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description thomas.bartschies 2001-05-03 04:29:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT)

Description of problem:
the command:
image create pixmap -file "/home/xxx/example.xpm"
results in the error message
unknown option ""
although the info image types commands says that tix supports
bitmap pixmap photo ...
In RH 6.x this worked properly.

How reproducible:

Steps to Reproduce:
1. start "tixwish"
2. image create pixmap -file "any xpm file"

Actual Results:  Error message:
unknown option ""

Expected Results:  tcl/tk Image ID as a result string

Additional info:
Comment 1 Eido Inoue 2001-07-12 14:36:45 EDT
Fixed for the next release
Comment 2 Need Real Name 2002-12-11 03:15:20 EST
What was the "fix" havill is referring to? A patch in the RH release,
a RH build problem that was solved, or a tix upgrade?

AFAIK this has never been a bug in tix, as the xpm images
are covered in the test suite.

I have a new minor release ready to go but not yet announced.
Would you like to try it out and see if there is this problem?
It's a bugfix release with no major changes
to the configure/make.

Comment 3 Jens Petersen 2002-12-12 01:12:02 EST
Thanks for the followup.

As far as I can tell it was probably fixed by a version
(perhaps to tix-2.2b?).

Note You need to log in before you can comment on or make changes to this bug.