Bug 388891 - dangling symlink
dangling symlink
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: vdr-skins (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-17 16:19 EST by Florian La Roche
Modified: 2007-12-10 11:06 EST (History)
0 users

See Also:
Fixed In Version: 20061119-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-10 11:06:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florian La Roche 2007-11-17 16:19:13 EST
Description of problem:

vdr-skins has dangling symlink from
/usr/share/vdr/text2skin/Enigma/FontMonoSpaced.ttf to
/usr/share/fonts/dejavu-lgc/DejaVuLGCSansMono.ttf

regards,

Florian La Roche



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Ville Skyttä 2007-11-18 06:56:39 EST
Hm, could you clarify how this symlink is dangling - it is handled by a
dependency to dejavu-lgc-fonts, no?

$ rpm -qRp vdr-skins-20061119-3.noarch.rpm | grep deja
dejavu-lgc-fonts
$ rpmls dejavu-lgc-fonts-2.19-1.noarch.rpm | grep
/usr/share/fonts/dejavu-lgc/DejaVuLGCSansMono.ttf
-rw-r--r--  /usr/share/fonts/dejavu-lgc/DejaVuLGCSansMono.ttf
Comment 2 Florian La Roche 2007-11-18 10:33:34 EST
The current Fedora-devel rpm only contains the following mono fonts:
-rw-r--r--    1 root    root           264100 Oct 28 16:22
/usr/share/fonts/dejavu/DejaVuLGCMonoSans.ttf
-rw-r--r--    1 root    root           247740 Oct 28 16:22
/usr/share/fonts/dejavu/DejaVuLGCMonoSansBold.ttf
-rw-r--r--    1 root    root           194904 Oct 28 16:22
/usr/share/fonts/dejavu/DejaVuLGCMonoSansBoldOblique.ttf
-rw-r--r--    1 root    root           202304 Oct 28 16:22
/usr/share/fonts/dejavu/DejaVuLGCMonoSansOblique.ttf

So looks like a SansMono -> MonoSans rename did happen in the font package.

regards,

Florian La Roche

Comment 3 Ville Skyttä 2007-11-18 13:04:45 EST
Oh, thanks.  Looks like the dir changed as well.  Fixed in 20061119-4.
Comment 4 Florian La Roche 2007-12-09 17:57:30 EST
Hello Ville,

dejavu seems to have changed back again to the old names, so currently I get
the following warning about a dangling symlink:

vdr-skins has dangling symlink from
/usr/share/vdr/text2skin/Enigma/FontMonoSpaced.ttf to
/usr/share/fonts/dejavu/DejaVuLGCMonoSans.ttf

Existing path in current dejavu rpm package:
/usr/share/fonts/dejavu/DejaVuLGCSansMono.ttf

regards,

Florian La Roche
Comment 5 Ville Skyttä 2007-12-10 11:06:21 EST
Oh joy, thanks for the catch.  Adjusted for dejavu-lgc-fonts >= 2.22 in 20061119-5.

Note You need to log in before you can comment on or make changes to this bug.