Bug 38893 - Can not be compiled with original-kernel
Summary: Can not be compiled with original-kernel
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: quota   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-03 09:22 UTC by Enrico Scholz
Modified: 2007-04-18 16:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-03 15:55:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Enrico Scholz 2001-05-03 09:22:09 UTC
When trying to compile  quota-3.00-4.src.rpm with the original 2.4.[34]
Kernel I get a lot of errors:

--------------------
$ rpm --rebuild quota-3.00-4.src.rpm
...
Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.33940
gcc -O2 -march=i386 -mcpu=i686   -c -o setquota.o setquota.c
In file included from setquota.c:12:
/usr/include/linux/quota.h:117: parse error before `__u32'
...
In file included from setquota.c:15:
quota_io.h:35: parse error before `qid_t'
...
make: *** [setquota.o] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.33940 (%build)
    Bad exit status from /var/tmp/rpm-tmp.33940 (%build)
----------------------

The first error (this with '__u32') can be cured by a '#include
<asm/types.h>' in setquota:11; the second one (this with 'qid_t') seems to
be more difficultly because I have not found such a 'qid_t' datatype in my
system.

Comment 1 Bill Nottingham 2001-05-03 15:55:47 UTC
You *need* the -ac series to build quota, AFAIK - Alan?

Comment 2 Preston Brown 2001-07-02 20:07:50 UTC
yes.

Our quota package will only build with our kernel package, not the stock one.



Note You need to log in before you can comment on or make changes to this bug.