Bug 38895 - Boot failure if using sym53c8xx driver when using custom 2.2.19 kernel
Boot failure if using sym53c8xx driver when using custom 2.2.19 kernel
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-03 05:33 EDT by Need Real Name
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-21 06:00:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from dmesg showing the problem (9.83 KB, text/plain)
2001-05-03 05:34 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2001-05-03 05:33:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
When building a custom kernel from the Redhat version of 2.2.19 kernel 
sources I get SCSI problems with the sym53c8xx driver. The dmesg attached 
outlines the problems with the build. Please note, the machine boots 
approx 1 in 10 times (hence the dmesg) - other times I get a panic and the 
machine halts. I have tried this on PII and PIII platforms.

NOTE: **When compiling using the sources from www.kernel.org I do not have 
this problem**



How reproducible:
Always

Steps to Reproduce:
1. Use redhat 2.2.19 kernel-sources
2. Rebuild Kernel with sym53c8xx driver
3. Reboot - 1 in 10 times, the machine will reset the SCSI bus many times, 
but eventually boot. The remaining times, the boot will fail.
	

Additional info:

dmesg - see attached.
Comment 1 Need Real Name 2001-05-03 05:34:09 EDT
Created attachment 17187 [details]
Output from dmesg showing the problem
Comment 2 Arjan van de Ven 2001-05-03 05:36:39 EDT
Our 2.2.19 source is incompatible with reiserfs due to the Large File Support
that is included....
Comment 3 Arjan van de Ven 2001-05-03 05:37:37 EDT
Also, does our compiled 2.2.19 rpm work ?
Comment 4 Need Real Name 2001-05-03 06:08:17 EDT
Thanks for the reply.

The RedHat 2.2.17 pre-compiled kernel did work with my system, however I have 
not tried the pre-compiled 2.2.19 kernel.

Note You need to log in before you can comment on or make changes to this bug.