Bug 388951 - cups broken on a new installation of F8
cups broken on a new installation of F8
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
All Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 387791 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-17 17:20 EST by Michal Jaegermann
Modified: 2008-06-17 17:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-17 17:17:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
an output from 'ldd /usr/sbin/cupsd' with 'libdns_sd.so.1 => not found' (1.62 KB, text/plain)
2007-11-17 17:20 EST, Michal Jaegermann
no flags Details
install.log from the installation in question (28.98 KB, text/plain)
2007-11-17 17:21 EST, Michal Jaegermann
no flags Details

  None (edit)
Description Michal Jaegermann 2007-11-17 17:20:30 EST
Description of problem:

On a new F8 installation "from scratch" cups failed to start with
complaints about missing libdns_sd.so.1 library.  Indeed, ldd
also showed up (output attached) that this library is missing.
A quick search revealed that this library is supplied by
avahi-compat-libdns_sd package but that was not installed.

This was indeed a "customized" installation where only "Base"
and "GNOME Desktop" was selected and whatever else was installed
was picked up by anaconda.  An install.log file from that exercise
is attached too.  So this is a problem with cups package which
is missing dependency on avahi-compat-libdns_sd, or something
went awry with a resolver in anaconda, or avahi-compat-libdns_sd
should be listed as "mandatory" in Fedora-8-comps.xml if cups
has that status, or all of the above?

How reproducible:
no idea; tried that once
Comment 1 Michal Jaegermann 2007-11-17 17:20:30 EST
Created attachment 262511 [details]
an output from 'ldd /usr/sbin/cupsd' with 'libdns_sd.so.1 => not found'
Comment 2 Michal Jaegermann 2007-11-17 17:21:16 EST
Created attachment 262521 [details]
install.log from the installation in question
Comment 3 Michal Jaegermann 2007-11-17 21:52:42 EST
I realized that I can do another type of testing.  On an installation
with a problem I did 'rpm -e --nodeps cups' and after that I used
with yum _only_ that repository from which anaconda was installing
my test system.  Then I got from yum:

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Installing:
 cups                    i386       1:1.3.4-2.fc8    fedora-wkb        3.4 M
Installing for dependencies:
 avahi-compat-libdns_sd  i386       0.6.21-6.fc8     fedora-wkb         25 k
 paps                    i386       0.6.6-21.fc8     fedora-wkb         33 k

and all three packages installed without any issues.  I missed
paps before.

That prompted me to install yum-utils and do 'package-cleanup --problems'
Effects were like that:

Package firefox requires system-bookmarks
Package gstreamer-plugins-good requires libFLAC.so.8
Package gstreamer-plugins-good requires libavc1394.so.0
Package gstreamer-plugins-good requires libcdio.so.7
Package gstreamer-plugins-good requires libcdio.so.7(CDIO_7)
Package gstreamer-plugins-good requires libdv.so.4
Package gstreamer-plugins-good requires libiec61883.so.0
Package gstreamer-plugins-good requires libraw1394.so.8
Package gstreamer-plugins-good requires librom1394.so.0
Package gstreamer-plugins-good requires libshout.so.3
Package gstreamer-plugins-good requires libspeex.so.1
Package gstreamer-plugins-good requires libtag.so.1
Package gstreamer-plugins-good requires libwavpack.so.1

Once again - yum had no probles in finding all required
packages without going to any "external" repositories
(i.e. other that the one used in an installation) and now
'package-cleanup --problems' has no issues.

It appears that dependencies are missed somewhere on
an installation.  OTOH I did some updates from FC6 basically
in the same way (after applying a fix for bug 372011) and
I did not observe anything of that sort.

I wonder if this is not the same as bug 387791 which was
closed with WORKSFORME.  "Medium" in my case is surely
"clean" as repository was accessed via NFS and/or HTTP.
Comment 4 Moritz Barsnick 2007-11-18 08:28:20 EST
*** Bug 387791 has been marked as a duplicate of this bug. ***
Comment 5 Michal Jaegermann 2007-11-18 12:59:10 EST
That looks more and more like some resolver issue.  Changing
"component" from cups to anaconda.
Comment 6 Michal Jaegermann 2007-11-19 19:08:05 EST
Once more I did an experiment of putting up a "small" F8 (i386) installation
from scratch.  This time I was careful to have in customization eplicitly
choosen only two groups: "Gnome Desktop" and "Base".  I ended up installing
this time 587 packages.

After adding yum-utils I got the following from 'package-cleanup --problems':

Missing dependencies:
Package xorg-x11-xinit requires ConsoleKit-x11
Package xorg-x11-xinit requires xauth
Package xorg-x11-xinit requires xorg-x11-server-utils
Package xorg-x11-server-Xorg requires xkbcomp
Package xorg-x11-server-Xorg requires xkbdata
Package xorg-x11-server-Xorg requires xorg-x11-drv-evdev
Package xorg-x11-server-Xorg requires xorg-x11-drv-keyboard
Package xorg-x11-server-Xorg requires xorg-x11-drv-mouse
Package xorg-x11-server-Xorg requires xorg-x11-drv-vesa
Package xorg-x11-server-Xorg requires xorg-x11-drv-void
Package pirut requires comps-extras
Package pirut requires notify-python
Package firefox requires system-bookmarks
Package gstreamer-plugins-good requires libFLAC.so.8
Package gstreamer-plugins-good requires libavc1394.so.0
Package gstreamer-plugins-good requires libcdio.so.7
Package gstreamer-plugins-good requires libcdio.so.7(CDIO_7)
Package gstreamer-plugins-good requires libdv.so.4
Package gstreamer-plugins-good requires libiec61883.so.0
Package gstreamer-plugins-good requires libraw1394.so.8
Package gstreamer-plugins-good requires librom1394.so.0
Package gstreamer-plugins-good requires libshout.so.3
Package gstreamer-plugins-good requires libspeex.so.1
Package gstreamer-plugins-good requires libtag.so.1
Package gstreamer-plugins-good requires libwavpack.so.1

cups is now not on that list but other things are.
It looks that the problem is repeatable. 'firefox' and
'gstreamer-plugins-good' are affected the same way as before.
Comment 7 Andy Lindeberg 2008-06-03 14:42:19 EDT
Are you able to reproduce the problem in F9?
Comment 8 Michal Jaegermann 2008-06-04 02:29:11 EDT
I tried the same experiment with F9; i.e. I picked up in anaconda
only "Base" and "Gnome Desktop".  That installs now 645 packages
and nearly 2GB of stuff.  After that 'package-cleanup --problems'
does not report any issues.  OTOH such installation by default
attempts to start in a graphics modes and it fails with

Fatal server error:
no screens found

Not that surprising if one looks closer as the only display driver
which got installed is xorg-x11-drv-vesa and X attempts, quite correctly,
to use radeon - which is not there.

Another "weird" behaviour is that this fragment

            if [ -n "$ipaddr" ]; then
                    eval $(ipcalc -h $ipaddr 2>/dev/null)
                    hostname ${HOSTNAME}
            fi

of /etc/rc.d/rc.sysinit does not seem to be running and a host name
is left as localhost.localdomain.  When that code is executed later
then everything is set in an expected manner.  What is "missing" here
I do not know at this moment.

Comment 9 Andy Lindeberg 2008-06-04 09:45:05 EDT
Thank you for retesting. I'm going to move this to F9 bugs so it will get looked at.
Comment 10 Andy Lindeberg 2008-06-17 17:17:43 EDT
Since we would like for there to be only one bug per report, could you open new
reports with these issues? Since there seem to be no issues with the packages,
the fatal error you're seeing likely means missing drivers for your video card.

Note You need to log in before you can comment on or make changes to this bug.