Bug 389161 - no sound on P5B plus
no sound on P5B plus
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
i686 Linux
low Severity high
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-11-18 03:08 EST by gms2567
Modified: 2008-02-25 10:31 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-02-25 10:31:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
log file (51.41 KB, text/plain)
2007-11-18 03:08 EST, gms2567
no flags Details

  None (edit)
Description gms2567 2007-11-18 03:08:16 EST
Description of problem:
There is no a sound after installation Fedora  8.
Motherboard - Asus P5B Plus with audio ADI 1988

Version-Release number of selected component (if applicable): alsa-lib-

How reproducible:

Steps to Reproduce:
1.Run system-sound-config
Actual results: 

I have a message:
Automatic detection of the sound card did not work.  This audio device will not
be available on the system.

You can find log files /root/scsconfig.log, /root/scsrun.log and file a new bug
at http://bugzilla.redhat.com.

Please click OK to continue.

Expected results:

Additional info:
Comment 1 gms2567 2007-11-18 03:08:16 EST
Created attachment 262711 [details]
log file
Comment 2 gms2567 2007-11-19 10:46:37 EST
I tried the maggic string "options snd-hda-intel model=3stack" in modprobe.conf 
but nothing results. Help!
Comment 3 Martin Stransky 2007-11-26 17:30:37 EST
Hm, log looks sane, I don't see any problem there. I looks like your hardware is
now fully supported yet. Please check www.alsa-project.org site and report your
problem there (and attach the log there).
Comment 4 gms2567 2007-11-30 12:25:09 EST
Hello, Martin!

Great thanks for your suggestion.

But I have some questions, may be you help me to find answers. Looking to the 
file srcrun.log I see some strings which I don’t understand:

Playing WAVE '/usr/share/system-config-soundcard/sound-sample.wav' : Signed 16 b
it Little Endian, Rate 44100 Hz, Stereo
cat: /etc/asound.conf: no such file or directory
FATAL: Module snd_hda_intel is in use.
cat: /etc/asound.conf: no such file or directory
ProbeCards, method =  hal

What does it mean? Why files asound.conf or  asoundfc are absent? Why module
snd_hda_intel is busy? May be thanks for pulseaudio? How can I check it?

Before installation Fedora 8 I tried Mandriva 2008 Free and after writing string
model=3stack in modeprobe.conf sound with same module worked perfectly.

Best regards,
Comment 5 Will Woods 2007-12-03 14:49:11 EST
asound.conf is created by system-config-soundcard, so it's not expected to be
there until that runs successfully.

you can check to see if pulseaudio is running like this:
pulseaudio --check && echo "pulseaudio running"

if pulseaudio is running, that would explain why system-config-soundcard could
not remove the snd_hda_intel module.

Did you reboot after modifying modprobe.conf?

Note You need to log in before you can comment on or make changes to this bug.