Bug 389351 - Package Updated dialog's details pane does not provide version number information
Package Updated dialog's details pane does not provide version number informa...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Luke Macken
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-18 08:54 EST by Oded Arbel
Modified: 2016-09-19 22:38 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.3.31-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-11 00:33:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Oded Arbel 2007-11-18 08:54:32 EST
Description of problem:
When using the Package Updated (pup) to list the available updates, the details
pane at the bottom of the dialog provides some information as to what is being
updated. The "Description" field sometimes has some text that may or may not be
helpful, but much more important information - the version numbers of the
packages being updated is missing. At the minimum I would expect to know the new
version number of the package being updated (so I can compare it to the versions
available on other computers), but I would also like to see the version number
before the update.

Version-Release number of selected component (if applicable):
1.3.25-2.fc8

How reproducible:
Always

Steps to Reproduce:
1. When new updates are available, click "view updates" in the pup notification
tray icon's menu.
2. Select an update and unfold the "Defails" pane.
3. Try to guess what version of the package is currently installed and what new
version will be installed by the updater.
  
Actual results:
No version numbers anywhere

Expected results:
Some hint as to what version I'm going to get

Additional info:
Its very important, because if a friend tells me something like "You have to
update to Firefox 2.0.0.9 otherwise bad stuff will happen" then I want to know
that I actually got that version.
Comment 1 Luke Macken 2008-05-12 23:01:30 EDT
Added in pirut commit 00bd034a967df736ae642c3bc8d08fca2d17cce6.  Better late
than never :)

Jeremy, I'm not sure if you were planning to do a pirut update at any point soon?
Comment 2 Fedora Update System 2008-05-30 22:13:30 EDT
pirut-1.3.31-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pirut'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-4718
Comment 3 Fedora Update System 2008-06-11 00:33:56 EDT
pirut-1.3.31-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.