Bug 389371 - Synaptic will not retrieve updated repo information
Synaptic will not retrieve updated repo information
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: synaptic (Show other bugs)
8
i386 Linux
low Severity high
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-18 09:28 EST by Tom
Modified: 2007-12-06 12:39 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.57.2-14.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-06 12:39:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom 2007-11-18 09:28:39 EST
Description of problem:
Synaptic will not retrieve updated repo information

Version-Release number of selected component (if applicable):
0.57.2-13.fc8

How reproducible: Always


Steps to Reproduce:
1. Execute Synaptic
2. Click Reload
3.
  
Actual results: Updated repo information is not loaded, only installed packages
displayed


Expected results: Updated repo information loaded


Additional info:
Comment 1 Panu Matilainen 2007-11-19 02:17:05 EST
This is possibly a dupe of bug 385081 - if you update fedora-package-config-apt
to version 8-1, does this problem go away?
Comment 2 Tom 2007-11-19 09:20:22 EST
No that is the version I currently have installed
Comment 3 Panu Matilainen 2007-11-19 10:37:06 EST
Ok I can actually reproduce that now too... Something funny here as simple
rebuild seems to fix it although there's no difference in the apt version the
current version was built against. Eeh.

Oh well, there's at least one "trivial" Synaptic bug open anyway, might as well
fix it now so it gets the rebuild it seems to need...

Comment 4 Tom 2007-11-24 09:36:52 EST
I just rebuilt synaptic and that does fix the problem.

I assume that somehow the build that got released didn't properly take the
synaptic-0.57.2-repomd-1.patch?  I noticed yesterday that the repository
configuration was only listing deb types, after the rebuild I have repomd & rpm
sources present.
Comment 5 Panu Matilainen 2007-11-26 02:47:13 EST
Reopening - it very much is a bug in the package if it requires rebuilding in
order to work :)

Something funny going on in here anyway, missed patch or something such. The
latest rebuild was a mass-rebuild for some ppc32 issue and maybe something that
was supposed to get included there didn't - dunno. Anyway, I'll rebuild it and
push an update.
Comment 6 Panu Matilainen 2007-11-26 03:16:21 EST
Ok, rebuilt + submitted to testing...
Comment 7 Fedora Update System 2007-11-26 13:38:53 EST
synaptic-0.57.2-14.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update synaptic'
Comment 8 Tom 2007-11-27 13:25:28 EST
Hmmm, did I accidently close this bug?
Comment 9 Fedora Update System 2007-12-06 12:39:36 EST
synaptic-0.57.2-14.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.