Bug 38949 - Can't mount CDROM with mount-2.10r-0.6.x under 6.2 alpha
Summary: Can't mount CDROM with mount-2.10r-0.6.x under 6.2 alpha
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 6.2
Hardware: alpha
OS: Linux
high
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-03 13:54 UTC by jnam1
Modified: 2005-10-31 22:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-03 15:27:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description jnam1 2001-05-03 13:54:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0; compaq)

Description of problem:
mount-2.10r-0.6.x cannot mount ISO9660 CDROM under 6.2 alpha.
The CDROM is EIDE type. Here goes the dmesg:

# mount -t iso9660 -o ro /dev/cdrom /mnt/cdrom

ISO 9660 Extensions: Microsoft Joliet Level 1
hda: tray open
end_request: I/O error, dev 03:00 (hda), sector 140
ISOFS: unable to read i-node block
ISOFS: changing to secondary root
hda: tray open
end_request: I/O error, dev 03:00 (hda), sector 2280
ISOFS: unable to read i-node block
isofs_read_super: root inode not initialized


How reproducible:
Always

Steps to Reproduce:
1. insert CDROM
2. type: #mount -t iso9660 -o ro /dev/cdrom /mnt/cdrom

	

Actual Results:  type 'dmesg' to see what happened with cdrom

ISO 9660 Extensions: Microsoft Joliet Level 1
hda: tray open
end_request: I/O error, dev 03:00 (hda), sector 140
ISOFS: unable to read i-node block
ISOFS: changing to secondary root
hda: tray open
end_request: I/O error, dev 03:00 (hda), sector 2280
ISOFS: unable to read i-node block
isofs_read_super: root inode not initialized


Additional info:

Comment 1 Bernhard Rosenkraenzer 2001-05-03 14:59:22 UTC
This looks like a broken drive or a broken medium to me.
Definitely not a mount bug, assigning to kernel because if it's a bug (which I 
doubt), it's a kernel bug.

Comment 2 jnam1 2001-05-03 15:27:04 UTC
Hi,

I am also running two redhat-6.2 x86 boxes here.
They have all the recent updates from updates.redhat.com
and both machines are identical in terms of rpms loaded.

They are now running mount-2.10r-0.6.x.i386 and the same cdrom
which you were suspicious of its being broken reads simply
perfect on both x86 boxes.

Yes, this could be alpha specific kernel issue. But RedHat still
should provide a working 'mount' binary consistent with the
following rpms anyway by updating whatever found to be broken
among them.

. kernel-2.2.19-6.2.1.alpha
. util-linux-2.10r-0.6.x.alpha (maybe irrelevant but not yet available)
. losetup-2.10r-0.6.x.alpha (found to be built from util-linux-2.10r)
. mount-2.10r-0.6.x.alpha (found to be built also from util-linux-2.10r)

While trying to downgrade mount-2.10r, rpm message says I cannot
go back to the previous 2.2.16-3 because it requires kernel >= 2.2.19.

regards,
Joonwoo


Comment 3 Phil Copeland 2001-06-04 20:02:58 UTC
Since fixed


Comment 4 jnam1 2001-06-04 22:44:06 UTC
So,  what has been fixed ?
Do you think this is not because of the kernel but because of the hardware issue
itself ?
Joonwoo



Note You need to log in before you can comment on or make changes to this bug.