Bug 3895 - X server still crashes a la PR#2818...
X server still crashes a la PR#2818...
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
6.0
sparc Linux
high Severity high
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-07-04 06:06 EDT by phiber
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-08-31 15:08:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description phiber 1999-07-04 06:06:00 EDT
As per PR#2818, I upgraded egcs to 1.1.2-13, and rebuilt
a kernel from 2.2.5-22 sources.  Somewhat at random, most
recently after a few hours, the session manager crashes in
gnome, the session exits back to the gdm login screen, and
a core file from "ed" is left in my home directory.
After which gnome fails to come back up properly.
This happened last when I was changing xscreensaver
settings, if that matters at all.
This has become EXTREMELY annoying, as this makes getting
any work done nearly impossible.

Please help!!!
Thanks.
-Mark Abene
phiber@noc.untraceable.net
Comment 1 phiber 1999-07-05 02:19:59 EDT
And by the way, I *am* using the latest XFree86 and xscreensaver
rpms from the current/updates directory.  Doesn't make a difference!
Comment 2 phiber 1999-07-05 02:22:59 EDT
I've just tried rebuilding the 2.2.5-22 kernel with egcs 1.0.3, as a
test.  X *still* crashes the exact same way.  core file from 'ed'.
Window manager doesn't matter.
I'm now in the process of building gcc-2.7.2.3 from the source rpm,
after which I will try rebuilding the kernel again.
Are you guys sure this is a compiler problem, and not an X problem?
Everything other than X seems stable...
Comment 3 phiber 1999-07-05 02:24:59 EDT
By the way, I should probably mention, I'm using a SS Voyager (i.e.
SS5 guts, MicroSPARC 2, cgsix, etc.)
I hope I'm providing enough details.  I really want to see this fixed,
since it's plaguing so many people.  Maybe a cgsix specific problem?
Comment 4 Preston Brown 1999-07-06 11:23:59 EDT
Dave, do you have any comments on this one?  Sorry to toss you into
the fray...
Comment 5 phiber 1999-07-10 01:38:59 EDT
I would have to say at this point that egcs for sparc is broken.
After rebuilding the kernel with gcc-2.7.2.3, gnome has not crashed
AT ALL.  Their have been some core dumps, such as when trying to
access screensaver settings, but the dumping didn't bring down the
whole X server like before.  Since gnome was probably built with the
same broken egcs, I'm tempted to blame it for the core dumping.
As of right now, I've been up running gnome for nearly a week.
Comment 6 Preston Brown 1999-08-31 15:08:59 EDT
There are a number of XFree86 fixes for SPARC in the forthcoming 3.3.5
errata release.  Please re-open this bug if your problems persist
after updating.

Note You need to log in before you can comment on or make changes to this bug.