Bug 39034 - Generated XF86Config file is missing quotes (640x480 on VGA16)
Generated XF86Config file is missing quotes (640x480 on VGA16)
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-03 18:25 EDT by Peter Fales
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-20 03:33:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Fales 2001-05-03 18:25:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.18 i686)

Description of problem:
There some quotes missing in Xconfigurator.c from Xconfigurator-4.9.27. 
This results
in a syntactically invalid XF86Config file.  (And if you're wondering why
I'm doing kickstart
tests on a machine with 256K VGA card,  it's because that's what the VMware
"virtual PC"
provides for its display hardware).  Here's the patch

diff -ur Xconfigurator-4.9.27.orig/Xconfigurator.c
Xconfigurator-4.9.27/Xconfigurator.c
--- Xconfigurator-4.9.27.orig/Xconfigurator.c   Wed Mar 28 14:35:51 2001
+++ Xconfigurator-4.9.27/Xconfigurator.c        Thu May  3 17:16:13 2001
@@ -2330,7 +2330,7 @@
     state->modesline8bpp = "\"800x600\" \"640x480\"";
     state->modesline16bpp = "\"640x400\"";
   } else if (state->videomemory >= 256) {
-    state->modesline8bpp = "640x480";
+    state->modesline8bpp = "\"640x480\"";
   }
  
   if (state->videomemory < 256) {
@@ -2381,7 +2381,7 @@
     state->modesline8bpp = "\"800x600\" \"640x480\"";
     state->modesline16bpp = "\"640x400\"";
   } else if (state->videomemory >= 256) {
-    state->modesline8bpp = "640x480";
+    state->modesline8bpp = "\"640x480\"";
   } else {
     if (!kickstart) {
       newtWinMessage(_("X Error"), _("Ok"),
@@ -2496,7 +2496,7 @@
            state->modesline8bpp = "\"800x600\" \"640x480\"";
            state->modesline16bpp = "\"640x400\"";
          } else if (state->videomemory >= 256) {
-           state->modesline8bpp = "640x480";
+           state->modesline8bpp = "\"640x480\"";
          } else {
            printf(_("Fatal error: Invalid amount of video memory.\n"));
            exit(-1);



How reproducible:
Always

Steps to Reproduce:
1.  Run "Xconfigurator --kickstart" on a machine with a generic 256K VGA
card
2.   Run "X"
3.
	

Actual Results:  Aborts with syntax error - sees 640x480

Expected Results:  Should see "640x480" for the mode  (i.e. with quotes)


Additional info:
Comment 1 Mike A. Harris 2001-05-22 04:08:39 EDT
Thanks very much for pointing this bug out.  I've fixed it in CVS now.

Note You need to log in before you can comment on or make changes to this bug.