Bug 390411 - Some (maybe optional) missing BuildRequires
Some (maybe optional) missing BuildRequires
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdelibs (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-19 09:14 EST by Sebastian Vahl
Modified: 2010-12-07 13:40 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-09 14:16:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sebastian Vahl 2007-11-19 09:14:35 EST
Description of problem:
When looking into BUILD/kdelibs-3.96.0/i386-redhat-linux-gnu/CMakeCache.txt
there are listed some missing BuildRequires:

HSPELL_INCLUDE_DIR:PATH=HSPELL_INCLUDE_DIR-NOTFOUND
HSPELL_LIBRARIES:FILEPATH=HSPELL_LIBRARIES-NOTFOUND
KRB5_CONFIG:FILEPATH=KRB5_CONFIG-NOTFOUND
MEMORYCHECK_COMMAND:FILEPATH=MEMORYCHECK_COMMAND-NOTFOUND
QT_QTMOTIF_INCLUDE_DIR:PATH=QT_QTMOTIF_INCLUDE_DIR-NOTFOUND
QT_QTMOTIF_LIBRARY:FILEPATH=QT_QTMOTIF_LIBRARY-NOTFOUND
QT_QTNSPLUGIN_INCLUDE_DIR:PATH=QT_QTNSPLUGIN_INCLUDE_DIR-NOTFOUND
QT_QTNSPLUGIN_LIBRARY:FILEPATH=QT_QTNSPLUGIN_LIBRARY-NOTFOUND
SCPCOMMAND:FILEPATH=SCPCOMMAND-NOTFOUND
SVNCOMMAND:FILEPATH=SVNCOMMAND-NOTFOUND
X11_XTest_LIB:FILEPATH=X11_XTest_LIB-NOTFOUND
X11_Xaccessrules_INCLUDE_PATH:PATH=X11_Xaccessrules_INCLUDE_PATH-NOTFOUND
X11_Xcomposite_INCLUDE_PATH:PATH=X11_Xcomposite_INCLUDE_PATH-NOTFOUND
X11_Xcomposite_LIB:FILEPATH=X11_Xcomposite_LIB-NOTFOUND
X11_Xdamage_INCLUDE_PATH:PATH=X11_Xdamage_INCLUDE_PATH-NOTFOUND
X11_Xdamage_LIB:FILEPATH=X11_Xdamage_LIB-NOTFOUND
X11_Xkbfile_INCLUDE_PATH:PATH=X11_Xkbfile_INCLUDE_PATH-NOTFOUND
X11_Xkbfile_LIB:FILEPATH=X11_Xkbfile_LIB-NOTFOUND
X11_Xpm_INCLUDE_PATH:PATH=X11_Xpm_INCLUDE_PATH-NOTFOUND
X11_Xpm_LIB:FILEPATH=X11_Xpm_LIB-NOTFOUND
X11_Xscreensaver_LIB:FILEPATH=X11_Xscreensaver_LIB-NOTFOUND
X11_Xv_INCLUDE_PATH:PATH=X11_Xv_INCLUDE_PATH-NOTFOUND
X11_Xv_LIB:FILEPATH=X11_Xv_LIB-NOTFOUND
X11_Xxf86misc_LIB:FILEPATH=X11_Xxf86misc_LIB-NOTFOUND


Most of them could be fulfilled by requiring these packages:

libXcomposite-devel
libXdamage-devel
libxkbfile-devel
libXpm-devel
libXv-devel
libXxf86misc-devel
libXtst-devel
libXScrnSaver-devel
openssh-clients
subversion


With these BRs the list is shorter:

HSPELL_INCLUDE_DIR:PATH=HSPELL_INCLUDE_DIR-NOTFOUND
HSPELL_LIBRARIES:FILEPATH=HSPELL_LIBRARIES-NOTFOUND
KRB5_CONFIG:FILEPATH=KRB5_CONFIG-NOTFOUND
MEMORYCHECK_COMMAND:FILEPATH=MEMORYCHECK_COMMAND-NOTFOUND
QT_QTMOTIF_INCLUDE_DIR:PATH=QT_QTMOTIF_INCLUDE_DIR-NOTFOUND
QT_QTMOTIF_LIBRARY:FILEPATH=QT_QTMOTIF_LIBRARY-NOTFOUND
QT_QTNSPLUGIN_INCLUDE_DIR:PATH=QT_QTNSPLUGIN_INCLUDE_DIR-NOTFOUND
QT_QTNSPLUGIN_LIBRARY:FILEPATH=QT_QTNSPLUGIN_LIBRARY-NOTFOUND

I'm not sure about "KRB5_CONFIG:FILEPATH=KRB5_CONFIG-NOTFOUND", because
krb5-devel is also required.



Version-Release number of selected component (if applicable):
kdelibs4-3.96.0-1
Comment 1 Kevin Kofler 2008-04-09 14:16:57 EDT
Solved long ago ("long" in KDE 4 terms ;-) ).

Note You need to log in before you can comment on or make changes to this bug.