Bug 39048 - Internal compiler error when compiler pro64, prompted to report a bug
Summary: Internal compiler error when compiler pro64, prompted to report a bug
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc   
(Show other bugs)
Version: 6.2
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: David Lawrence
URL: http://www.cs.ualberta.ca/~pengzhao/i...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-03 23:34 UTC by Peng Zhao
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-03 23:51:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
temporary file generated with "-save_temps" on (230.47 KB, patch)
2001-05-03 23:50 UTC, Peng Zhao
no flags Details | Diff

Description Peng Zhao 2001-05-03 23:34:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.73 [en] (X11; U; Linux 2.2.16-3 i686)

Description of problem: (error caused by gcc version 2.95.2 19991024
(release))
../../cygnus_20000828/bfd/ipa_ld.c:183: Internal compiler error in
`int_mode_for_mode', at stor-layout.c:202
Please submit a full bug report.


How reproducible:
Always

Steps to Reproduce:
1. gcc -DHAVE_CONFIG_H -DIPA_LINK -I. -I../../cygnus_20000828/bfd -I.
-D_GNU_SOURCE -I. -I../../cygnus_20000828/bfd
-I../../cygnus_20000828/bfd/../include -I../../cygnus_20000828/bfd/../intl
-I../intl -W -Wall -g -O2 -D__MIPS_AND_IA64_ELF_H -I/usr/sgi/include/
-L/usr/sgi/lib64 -c ../../cygnus_20000828/bfd/ipa_ld.c -o ipa_ld.o
-save-temps

2.
3.
	

Actual Results:   gcc -DHAVE_CONFIG_H -DIPA_LINK -I.
-I../../cygnus_20000828/bfd -I. -D_GNU_SOURCE -I.
-I../../cygnus_20000828/bfd -I../../cygnus_20000828/bfd/../include
-I../../cygnus_20000828/bfd/../intl -I../intl -W -Wall -g -O2
-D__MIPS_AND_IA64_ELF_H -I/usr/sgi/include/ -L/usr/sgi/lib64 -c
../../cygnus_20000828/bfd/ipa_ld.c -o ipa_ld.o -save-temps
../../cygnus_20000828/bfd/ipa_ld.c: In function `always_demangle':
../../cygnus_20000828/bfd/ipa_ld.c:94: warning: unused parameter `name'
../../cygnus_20000828/bfd/ipa_ld.c:94: warning: unused parameter `Demangle'
../../cygnus_20000828/bfd/ipa_ld.c: In function `read_one_section':
../../cygnus_20000828/bfd/ipa_ld.c:96: warning: unused parameter `index'
../../cygnus_20000828/bfd/ipa_ld.c:96: warning: unused parameter `p_void'
../../cygnus_20000828/bfd/ipa_ld.c: In function `merge_ext':
../../cygnus_20000828/bfd/ipa_ld.c:98: warning: unused parameter `p_sym'
../../cygnus_20000828/bfd/ipa_ld.c:98: warning: unused parameter `name'
../../cygnus_20000828/bfd/ipa_ld.c:98: warning: unused parameter `num'
../../cygnus_20000828/bfd/ipa_ld.c:98: warning: unused parameter `p_obj'
../../cygnus_20000828/bfd/ipa_ld.c: In function `msg':
../../cygnus_20000828/bfd/ipa_ld.c:101: warning: unused parameter `type'
../../cygnus_20000828/bfd/ipa_ld.c:101: warning: unused parameter `msg_id'
../../cygnus_20000828/bfd/ipa_ld.c: In function `do_compile':
../../cygnus_20000828/bfd/ipa_ld.c:183: Internal compiler error in
`int_mode_for_mode', at stor-layout.c:202
Please submit a full bug report.


Expected Results:  success in the compilation

Additional info:

[pengzhao@peers ~]$ gcc -v
Reading specs from
/usr/brule12/grad/pengzhao/tools/lib/gcc-lib/i686-pc-linux-gnu/2.95.2/specs
gcc version 2.95.2 19991024 (release)

Following is the temporary file  I generated with -save-temps flags on.

http://www.cs.ualberta.ca/~pengzhao/ipa_ld.i

Comment 1 Peng Zhao 2001-05-03 23:50:58 UTC
Created attachment 17268 [details]
temporary file generated with "-save_temps" on

Comment 2 Jakub Jelinek 2001-05-04 13:13:36 UTC
We haven't ever shipped gcc 2.95.x as part of any Red Hat Linux distribution.
If it is a compiler you compiled yourself, please report it to GNATS
(look at http://gcc.gnu.org/), otherwise please see with anyone who provided
you the compiler.
The compiler we ship (gcc-2.96-RH) seems to compile this just fine, egcs 1.1.x
cannot be checked since the preprocessed source uses features which are not
present in that compiler.


Note You need to log in before you can comment on or make changes to this bug.